Thank you for your donation!


Mount Synology NAS?
#1
I have 6.4.2 and a newish Synology NAS (DS1019+), which I can't mount in MoOde to save my life. I can mount it fine from Windows so I know that the address/credentials/protocols are good, but no love in MoOde. Protocol = SMB, tried the Guest rec and the proper credentials and a lot of the recs from the forums version=default, etc... No joy. Tried by name and ip address. Any leads on how to get this going?

Thanks,

     John

PS The SMB scan function is intermitent.
Reply
#2
Here is the log file output. 

20200314 144933 worker: Job sourcecfg
20200314 144934 sourceMount(): Mount error: (mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20200314 144937 worker: Job updmpddb
Reply
#3
(03-14-2020, 06:52 PM)Listener Wrote: Here is the log file output. 

20200314 144933 worker: Job sourcecfg
20200314 144934 sourceMount(): Mount error: (mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20200314 144937 worker: Job updmpddb

In experiments I've done with moOde and SMB servers in the past, error 13 has occurred when the host IP/or name and the share name were correct but the userID and/or password were not.

I've been meaning to start a FAQ on the error codes I've been able to generate with various purposeful "mistakes". Looks like I need to git-er-done.

Regards,
Kent
Reply
#4
I had this problem with Volumio in the past. Check your squash settings. If set to "no mapping", try changing to "map root to admin". This worked for me.
Reply
#5
Hi Kent,

To verify that I had the address, names, protocol, and credentials correct I mounted that directory to Win10, which worked perfectly.

Has anybody had success mounting a Synology shared directory to MoOde? If so, what settings did you use both on the MoOde side and the Synology side.

Thanks in advance,
      John
Reply
#6
(03-16-2020, 01:54 PM)Thram345 Wrote: I had this problem with Volumio in the past.  Check your squash settings.  If set to "no mapping", try changing to "map root to admin".  This worked for me.

Hey Thram,


I haven't been able to find the squash settings. can you tell me where they are?

Thanks,

      John
Reply
#7
John,

I may be getting a bit ahead of you. You may need to change the squash settings after the drive is mounted. I put the directions below anyway.

I mounted my DS218j without too much trouble. Be sure to use samba, then scan for a path. You're looking for a shared resource so make sure you put in the host/share. Also, as previously stated, username and password have to be correct.

Squash setting: Assuming you are using Disk Station software to manage your NAS:

Open the Control Panel.
Under File Sharing, open "Shared Folder".
You should see the folders on your NAS, like "home" and "music". Click on music to highlight, then click Edit.
On the "Edit Shared Folder music" screen, click on the tab marked "NFS Permissions".
You should see you clients IP addresses, for instance I have 2, one for hardwired ethernet and the other for wireless. You should also see the squash setting, which I'm guessing are set to "No Mapping".
Click to highlight a client IP. Click edit. You should see a drop down box for squash settings. I changed mine to "Map root to admin".
Click OK. Do this for your remaining client IP's. Save your way out.

Tom
Reply
#8
(03-16-2020, 03:37 PM)Listener Wrote: Hi Kent,

To verify that I had the address, names, protocol, and credentials correct I mounted that directory to Win10, which worked perfectly.
...
John,
I'm not going to debate how to set up Synology. I don't own any Synology products. Looks like @Thram345 is on the job.
But to clear up any misconceptions that may be lurking here, Synology's DSM is running on Linux and uses the same Samba software to deal with SMB shares that moOde running on Raspbian/Linux does. The error code I cited isn't somehow lying. Something is wrong with the combination of host/share/protocol/credentials is not correct.
Regards,
Kent
Reply
#9
(03-16-2020, 05:32 PM)TheOldPresbyope Wrote:
(03-16-2020, 03:37 PM)Listener Wrote: Hi Kent,

To verify that I had the address, names, protocol, and credentials correct I mounted that directory to Win10, which worked perfectly.
...
John,
I'm not going to debate how to set up Synology. I don't own any Synology products. Looks like @Thram345 is on the job.
But to clear up any misconceptions that may be lurking here, Synology's DSM is running on Linux and uses the same Samba software to deal with SMB shares that moOde running on Raspbian/Linux does. The error code I cited isn't somehow lying. Something is wrong with the combination of host/share/protocol/credentials is not correct.
Regards,
Kent
Reply
#10
Hey Kent,

I appreciate all you do for the community and I am not trying to be a problem, just looking for some hints on how to solve my mounting problem. To summarize, I can successfully mount the share to win10, I can administer the NAS via both the Synology desktop client and the web interface, I can ssh into it via puTTY, and backup to it via Acronis. The ONLY thing I cannot do is mount a share to MoOde. Any hints as to what I might try would be greatly appreciated. (I am able to mount a QNAP share to MoOde.)

Thanks in advance to anyone with a hint!

John
Reply


Forum Jump: