Thank you for your donation!

Moode doesn't explore my partitions on a USB drive

I am a new user of moode audio. I am grateful to devs that have made such a useful tool, i like ideas and design of moode.

However I met an issue trying to listen to my own music. Install on a raspberry pi 4 (2 Go), wifi and audio config worked well. But moode, or mpd in moode, is unable to discover my music tracks on a USB drive. Here are a few clues :
- last 6.4.2 moode audio on a 16 Gb sd card. Internet radio are OK. Music from an fat32 formatted USB stick ca be used without any issues.

- USB drive with its own power supply, 1 To, WD.
- two partitions : an ext4 one with all my "home" folder (where on can find my music folder among a lot of other docs), and a ntfs one with only movies.

- the USB drive is seen and mounted under /media when used on the raspberry pi with moode audio. lsblk output :
pi@moode:~ $ lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT                                                                                                                                              
sda           8:0    0 931.5G  0 disk                                                                                                                                                        
├─sda1        8:1    0   395G  0 part /media/Sauvegardes                                                                                                                                      
└─sda2        8:2    0 536.6G  0 part /media/Films                                                                                                                                            
mmcblk0     179:0    0  14.9G  0 disk                                                                                                                                                        
├─mmcblk0p1 179:1    0   256M  0 part /boot                                                                                                                                                  
└─mmcblk0p2 179:2    0   3.4G  0 part /                                                                                                                                                      

- fdisk output extract to read about formatting :
Device         Boot  Start     End Sectors  Size Id Type                                                                                                                                      
/dev/mmcblk0p1        8192  532479  524288  256M  c W95 FAT32 (LBA)                                                                                                                          
/dev/mmcblk0p2      532480 7700479 7168000  3.4G 83 Linux                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                             
Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors                                                                                                                            
Disk model: My Book                                                                                                                                                                          
Units: sectors of 1 * 512 = 512 bytes                                                                                                                                                        
Sector size (logical/physical): 512 bytes / 512 bytes                                                                                                                                        
I/O size (minimum/optimal): 512 bytes / 512 bytes                                                                                                                                            
Disklabel type: dos                                                                                                                                                                          
Disk identifier: 0xa0cf0455                                                                                                                                                                                                                                                                                                                                                       
Device     Boot     Start        End    Sectors   Size Id Type                                                                                                                                
/dev/sda1            2040  828297119  828295080   395G 83 Linux                                                                                                                              
/dev/sda2       828297216 1953523711 1125226496 536.6G  7 HPFS/NTFS/exFAT                                                                                                                    

- With ssh tool, I can go to /var/lib/mpd/music/USB and find there my /media/Sauvegardes partition. I can manually go down to my music folder and find all my tracks.
- But in moode, when I "regen" library, it can only find some weird tracks in "movies" partition. No sign from my ext4 Documents partition.
- When I put a ".mpdignore" file a the root of the "movies" partition, moode find no tracks at all on my USB drive. It seems to ignore my ext4 partition.

- I tried with two other USB drive with same failures as far as discovering my music is concerned.

Moode can explore my fat32 formatted USB stick, but not my ext4 formatted partition on my USB drive.

What should I try to find my whole music folder under moode ? Is ext4 not a good format for mpd ? Is there a limit in the number of folders that mpd can explore ?

Thanks for the help you can provide !


Another information : When I copy an album folder from the Music folder to the partition root (eg : /media/Sauvegardes/Test_Album), moode can scan it and play it.

The same album in its normal place (/media/Sauvegardes/username/Music/Albums/Test_Album) cannot be found.

So it seems that either mpd scan cannot go further than a given number of folders, either something on the path to my music folder prevents it from further scanning.

I have tried to make a symbolic link to my music folder on the root of that partition (/media/Sauvegardes/Link_to_Music_Folder) to shorten the path to my music, but it does not work. Perhaps mpd cannot follow symbolic link ? If this behaviour could be changed, it could be a solution for me.

Welcome to any help,

It's prolly a permissions issue.

Examine the MPD log for errors while running database update

tail -f /var/log/mpd/log
cat /var/log/mpd/log
Hello Tim,

Thanks for your quick answer. You should be right, as I can read such lines :

Mar 14 16:27 : exception: Failed to open /var/lib/mpd/music/USB/Sauvegardes/username: Permission denied

"Sauvegardes" owner is root with rwxr-xr-x rights, but "username" owner is pi with only rwx------ rights. Who should be the owner of the mount point and the Music folder ? With which permissions ?

I changed permissions by adding r-x permissions to group and others. So permissions are : rwxr-xr-x, with user : pi and group : mpd. I made that change for parents folder of my Music folder.

When I launch a new library "regeneration" :
- it took less than a minute before the spinner stops
- with the tail -f /var/log/mpd/log command, I can see that a lot of tracks are "added" by mpd. Perhaps a few thousands (for 17 000 tracks in the Music folder). There is no more "permission denied" lines.
- with the same command, I see that the scan hangs on after a track. I cannot understand why it stops there. I have just played this track and the following on my PC, they seem fine. They have the same permissions that other tracks.
- the moode library shows no change, no tracks are here. I find strange that moode shows no track although mpd "added" some of them during its interrupted scan.

I could begin a new thread since the issue is another one and seems to be not related to permissions. But it is still about mpd scan process on a USB disk.

Some more help would be useful for me ! What should I try or check to have my whole library in moode ?


A few word to tell that your permission idea was the right one. My home folder on the USB drive (which is a backup of my real home folder) had no read rights for group, that's why mpd could not enter it and read my music.

I still have an issue with one of my folder inside my music folder (that had prevented mpd to go through its whole process), perhaps some corrupted tags, I will see later. I added a ".mpdignore" file with "*" in it in order mpd not to try to scan it.

Now I use moode on a daily basis and it's great !

Actually I use it with MPDroid on an android smartphone and it's very easy to use and nice to hear at.


Forum Jump: