Thank you for your donation!


Problem: Failed to open "ALSA default" (alsa); Failed to open ALSA device "hw:0,0"
#1
Good afternoon,

I am getting an error:
MPD Error

Failed to open "ALSA default" (alsa); Failed to open ALSA device "hw:0,0": No such file or directory

I am using Hifiberry DAC+ Pro HAT with Raspberry Pi 3B

I know this topic has come up before, and I've read through previous posts. What I've noticed is that most people have done one of two things:
  1. Turn off I2S audio DAC, restart, turn I2S audio DAC back on, restart -> everything works again
  2. Re-flash the whole moode audio, turn on I2S audio DAC -> everything works
I have tried method 1, and I am having no luck with it. I am hesitant to do method 2 as it means I loose all of the configuration, and have to re-configure from scratch. If there was a way to backup/restore configuration then I'd be ok with trying method two for now. I do understand that there are challenges associated with backup/restore of configuration (I've read the forum post).

Also, re-flash surely shouldn't be the solution to errors? How often will I need to re-flash? Weekly? Monthly? So with these comments what I am hoping for is a method to address the error that I am seeing, to try to get to the root of it and hopefully end up with a more stable system.

What's really odd about all of this is that everything was working fine for a few weeks. I then had the MPD error but it was 'fixed' with reboots. Now its there all the time. Maybe the Hifiberry DAC+ Pro is failing? I don't know enough to figure out what the problem may be.

Thanks for the help!

I've done some digging around and here is what I notice:
/var/log/mpd/log
ALSA lib pcm_hw.c:1822Sad_snd_pcm_hw_open) Invalid value for card
Mar 27 12:48 : exception: Failed to open "ALSA default" (alsa)
Mar 27 12:48 : exception: nested: Failed to open ALSA device "hw:0,0": No such file or directory

No I2S audio DAC has the following in the Audio info:
Decoded to:      0 bps
Destination:      Local
Output rate:      0 bps
DSP operations
Volume ctl:      Disabled (100% volume is output by MPD)
Resampling:      24 bit, 192 kHz, Stereo (SoX very high quality)
Polarity inv:      off
Crossfade:      off
Crossfeed:      off
Parametric EQ:      off
Graphic EQ:      off
Replaygain:      off
Normalize vol:      off
Chip options:      None
Audio Device
Device:      On-board audio device
Chip:      Broadcom SoC
Interface:      SOC
Formats:      U8, S16_LE
Platform:      Pi-3B 1GB v1.2


When I add Hifiberry DAC+ Pro I get the following changes in audio info:
Chip options:      FIR interpolation with de-emphasis, Gain=0dB, Boost=0dB
Audio Device
Device:      HiFiBerry DAC+ Pro
Chip:      Burr Brown PCM5122
Interface:      I2S
Formats:      cat: /proc/asound/card0/pcm0p/sub0/hw_params: No such file or directory



pi@moode:/var/log/mpd $ dmesg | grep hifiberry
[    6.816423] snd-rpi-hifiberry-dacplus socConfusedound: ASoC: CPU DAI (null) not registered - will retry
[    6.824268] snd-rpi-hifiberry-dacplus socConfusedound: ASoC: CODEC DAI pcm512x-hifi not registered - will retry

pi@moode:/var/log/mpd $ lsmod | grep hifi
snd_soc_hifiberry_dacplus    16384  0
snd_soc_core          192512  3 snd_soc_pcm512x,snd_soc_hifiberry_dacplus,snd_soc_bcm2835_i2s
snd_pcm               102400  5 snd_soc_pcm512x,snd_pcm_dmaengine,snd_soc_hifiberry_dacplus,snd_soc_bcm2835_i2s,snd_soc_core
clk_hifiberry_dacpro    16384  0

pi@moode:/var/log/mpd $ sudo aplay -l
aplay: device_list:272: no soundcards found...
Reply
#2
How topical...I have just fixed this on my HiFiBerry Digi+ Pro....

Firstly..try removing and reattaching the hiFiBerry HAT.
If that does not work then...

Ymmv but I am guessing there were several boards/batches that were not solder-flowed correctly...

My digi worked intermittently when first attached to the Pi....then not at all when removed and reattached... throwing exactly the error you are facing...
If you ssh in and try running..

Code:
alsamixer

you'll find a 'file not found' error.

So... if you have a multimeter , with the Pi running and HAT attached, measure the 5v point on the Hat's 40 pin  connector and then on the duplicate holes next to the 40 pin connector...  mine was 5v on the first and 1.7v on the other... (on the un-powered board I measured 23R between those pins..once reflowed it was unity)

I removed the HAT and  re-flowed the solder connection for both 5v pins on the main 40 pin connector on the HAT.... took several attempts each with a more sustained soldering...
I am thinking the multi-layered board has not been fully joined ex factory....

Remeasured and both measuring points  showed 5v
Rebooted...all errors gone and board played normally.

Used some Fry's  flux to enable the through-hole flow....again ymmv.

Cheers,
Bob.

(yes Mr Fry does look like the 'Pointy-haired Boss from the Dilbert cartoons' Lol

Alternative... if you're not confident/experienced with electronics then contact HiFiBerry and report a fault....especially if you're within the warranty.
This is an unacceptable manufacturing fault and should be covered even if out of warranty.

Note that there is a method to backup from within MoOde...only I can't remember how it goes.... Rolleyes
However... the RPI version works too....scroll down to 'SD card image' and use that.

https://www.raspberrypi.org/documentatio.../backup.md


Attached Files Thumbnail(s)
   
Reply


Forum Jump: