Thank you for your donation!


Problem: Does Moode makes a default recoding?
#1
Hi! First time Moode user here, noticed a strange behaviour.
My system is the following: RasperryPI running Moode>USB to a TAS1020 converter to SPDIF capable of max 96K>SPDIF input DAC based on ES9023 (Subbu DAC v3)

I noticed despite my digital chain is unable to decode files bigger 96kHz 24bit i can listed even to DSD audio files. Where is the recoding/downsampling done? I would like to listen to my files unchanged. I can live with my system limitations.

Thanks!
Reply
#2
What do you mean by "unable to decode files bigger 96kHz 24bit"?

If you are getting some sort of error messages then post them.
Reply
#3
Sorry if I wasn't clear enough. I have no errors and for USB to SPDIF conversion i use something lihe this: https://www.eliteaudiouk.com/product-pag...-interface

So this converter is limited to 24bit/96khz encoded files and i can play DSD or other files with higher encoding values and this should be not the case.
Where is this recoding done in Moode?
Reply
#4
ALSA by default will downsample to a rate, format and bit depth that the device accepts, otherwise the file won't play and an error would be generated.

If your USB/SPDIF converter is max 24/96 then it won't be possible to play higher bitrate files unless they are downsampled.
Reply
#5
Thanks for clarifying this Tim! Two more questions:
- can i be sure that my supported sample rates are bit perfect and only those unsupported are downsampled?
- if i want this, is possible to deactivate this feature of downsampling of Alsa?
Thanks a million! Adrian
Reply
#6
The files <= 24/96 will be left untouched unless you explicitly turn on SoX resampling or any of the DSP options for example replay gain, the EQ's, Crossfade etc. You can also verify what is being sent to the audio device by viewing Audio info. The Output rate line is what ALSA is sending to the audio device.

Yes, ALSA automatic resampling, format and channel conversion can be disabled by adding some options to the "ALSA default" audio_output block in /etc/mpd.conf. Note that this file gets overwritten when MPD config is saved and during moOde startup.
https://www.musicpd.org/doc/html/plugins...ample#alsa

-Tim
Reply
#7
Very useful info! Thanks Tim!
Reply


Forum Jump: