Thank you for your donation!


Problem: NuForce DAC100 Glitches above 16/44.1.
#1
Hello,

I'm using a PI4 4GB with Moode 6.5.0 (But problem was the same with 6.4.X).
Pi is connected via USB to my NuForce dac100 (10 years old) and when I play HD music I have glithes like it was playing under water and making bubbles Smile
I have try on the USB 2 and USB 3 of the Pi.
This was working properly with an old macbook and Audirvana.

I have tried to change some values in the /boot/config.txt :
dwc_otg.fiq_fsm_mask=0x* (I have try all the masks from 0 to 7 ;Wink  without any succes.

I also tried to lower the current on the interface, as the dac is self powered. 

Volumio as the same problem.

I know that this dac have a homemade usb interface, is this a problem with the Pi or with the linux drivers ?
"
The last "section" is the USB board, which appears very similar to the USB implementation I've seen in other NuForce products like the DAC-9, but different than my NuForce DDA-100 where USB is integrated into the main board itself. USB operates in asynchronous mode and the chip itself has NuForce labeling rather than one of the usual suspects like XMOS, VIA, C-Media, or Tenor.
"
If the drivers, any clue where to find The One ?


Dac100 review


Thanks !
Reply
#2
I think that you might be experiencing the "popping" problem about which there is a lengthy thread:

http://moodeaudio.org/forum/showthread.php?tid=205

The basis seems to be a USB mismatch between between the Pi4 and the DAC. I experienced something similar with an Audiolab M-DAC when using a Pi4, though it works fine using a Pi2B+.
Reply
#3
@GhezoArt

If the DAC interfaces via USB then there's no special driver out there to look for, it's just the Linux USB subsystem.
It sounds like you are already exercising the various bitmask "fixes" beyond the one the moOde System config allows you to set. As a last resort you might try the "dwc_otg.speed" kernel parameter. By default the Raspbian kernel configures the USB interface for USB 2.0 "High Speed" but this parameter can force it to USB 1.0 "Full Speed". I know this is just a shot in the dark. If the DAC is only 10 years old then it should have implemented USB 2.0, released in 2000, but maybe they flubbed it. The USB spec is notoriously difficult (almost as bad as Bluetooth!@*#!).
As @leicray has noted, there have been issues noted with a few other USB DACs, but there are many others which seem to work fine.
Have you asked your question on the diyaudio.com forum, I suppose on either the "PC based" or the "Digital Line Level" subforum? You're more likely to turn up other NuForce owners/devs there.
Regards,
Kent
Reply
#4
(04-26-2020, 03:57 PM)leicray Wrote: I think that you might be experiencing the "popping" problem about which there is a lengthy thread:

http://moodeaudio.org/forum/showthread.php?tid=205

The basis seems to be a USB mismatch between between the Pi4 and the DAC. I experienced something similar with an Audiolab M-DAC when using a Pi4, though it works fine using a Pi2B+.

Thanks, I'll read that.
FYI, I had the same problem with a Pi 3.
I think I have a P2 somewhere, I can try.

Thanks for your reply.
Reply
#5
(04-26-2020, 04:09 PM)TheOldPresbyope Wrote: @GhezoArt

If the DAC interfaces via USB then there's no special driver out there to look for, it's just the Linux USB subsystem.
It sounds like you are already exercising the various bitmask "fixes" beyond the one the moOde System config allows you to set. As a last resort you might try the "dwc_otg.speed" kernel parameter. By default the Raspbian kernel configures the USB interface for USB 2.0 "High Speed" but this parameter can force it to USB 1.0 "Full Speed". I know this is just a shot in the dark. If the DAC is only 10 years old then it should have implemented USB 2.0, released in 2000, but maybe they flubbed it. The USB spec is notoriously difficult (almost as bad as Bluetooth!@*#!).
As @leicray has noted, there have been issues noted with a few other USB DACs, but there are many others which seem to work fine.
Have you asked your question on the diyaudio.com forum, I suppose on either the "PC based" or the "Digital Line Level" subforum? You're more likely to turn up other NuForce owners/devs there.
Regards,
Kent
Reply
#6
Thx,

I have tryed without effect. Sad
I was looking on the internet but do you know how I can see that the setting is well applied ?

Regards.
Reply
#7
FYI and to close this thread, I sold the NuForce DAC and bought an Allo Revolution.
This is working fine !

Regards.
Reply
#8
(01-20-2021, 07:33 AM)GhezoArt Wrote: FYI and to close this thread, I sold the NuForce DAC and bought an Allo Revolution.
This is working fine !

Regards.

congrats to your new system :-)
btw: you can now edit title of thread -> solved.

regards, Martin
Reply


Forum Jump: