Thank you for your donation!


Moode 6.5 and Kazoo
#1
I can't get Tidal to work with 6.5.1 on Linn Kazoo.  It says I need Davaar 23.  It used to work with 6.4. Does anyone know how to fix this?  It works with all my other renderers (Volumio and Gentooplayer).  Bubbleupnp is running and Moode is made OpenHomeRenderer.  Any ideas would be appreciated.
Reply
#2
(04-28-2020, 05:57 PM)Zackthedog Wrote: I can't get Tidal to work with 6.5.1 on Linn Kazoo.  It says I need Davaar 23.  It used to work with 6.4. Does anyone know how to fix this?  It works with all my other renderers (Volumio and Gentooplayer).  Bubbleupnp is running and Moode is made OpenHomeRenderer.  Any ideas would be appreciated.

A quick search of the InterWeb™ reveals Davaar seems to be the name of a Linn package associated with providing OpenHome compatibility. I have no knowledge of Linn procedures but it sounds like you need to update your Linn Kazoo.

I'm listening to Tidal tracks as I write: Linn Kazoo on an iPad 9.7 (2018), Tidal credentials entered into the moOde 6.5.1 UPnP config/Kazoo configuration. In Linn Kazoo, I chose my moOde UPnP Renderer for output and it found the moOde UPnP media server (which proxies the Tidal media server) automagically.

I don't know how a problem with Linn Kazoo relates to the statement "Bubbleupnp is running and Moode is made OpenHomeRenderer. "

Regards,
Kent
Reply
#3
I'm using an Allo USBridge Signature, perhaps it has to to with the Allo. If I go back to 6.4.2 it works just fine.

With other players, you need to have Bubbleupnp running somwhere on the system and designate the player as an OpenHomeRenderer in order for Tidal to show up on Kazoo or Minimserver. With Moode it shouldn't be necessary but I do it anyway.
Reply
#4
@Zackthedog 

I don't believe the Allo has anything to do with your issue. There's an easy way to check---try using your Linn Kazoo app to control moOde directly via moOde's built-in UpnP Client for MPD. That's what I'm doing now as I just described. As well, I've now checked it against the Linn Kazoo app on my Android Pixel 3A phone---it's working just as well with moOde 6.5.1 as the iOS version is.

You're looking at three different pieces of software over which we have no control.

1) upmpdcli, which is incorporated into moOde from a third-party developer and which makes it possible to run moOde as a UPnP renderer. Many good and desirable bug fixes and enhancements have occurred to upmpdcli between the version in moOde 6.4 and the version in moOde 6.5.1. These changes have benefited moOde users but we had no control over their development.

2) Linn Kazoo. From moOde's standpoint, this is just another UPnP-speaking device. Again, it's upmpdcli which is doing the UPnP work.

3) BubbleUPnP. I have only a vague idea why you need this configuration but, again, to moOde it's just another UPnP-speaking device. I've used the BubbleUP client on my Android Pixel 3A phone with moOde to good effect but I've never tried to set up the three-way communication you seem to be describing.

Apparently a change in 1) causes 2) to complain when it communicates via 3). Yikes.

You've proposed to fix your issue by retreated to moOde 6.4. If all you are using moOde for is to turn your Allo into a UPnP renderer and media server, why not.


Another possible fix: If you must use Linn Kazoo, get Linn Davaar installed.

Another possible fix: use a different UPnP control point instead of Linn Kazoo. There are others; even Linn has more than one.

Regards,
Kent
Reply
#5
I use Tidal, plus Linn Kazoo on my Macbook with Moode 6.5.1 with no problems. No OpenHome Renderer though - I don't even know what it does.
Edit: I'm also able to use Tidal/Linn Kazoo via my Android tablet, but the app is a bit slow and clunky.
I have BubbleUPnP on the tablet too, and that's an alternative to Kazoo but I don't see the point of using the two in conjunction.
Reply
#6
My knowledge of Linn’s stuff is a bit hit ‘n miss but from what I gather Davaar is actually Linn’s bespoke firmware for its DSs (players) and until very recently Kazoo was its only control point to offer support for Tidal and indeed Qobuz.  Earlier this year ‘Linn App’ for iOS came out, a new control point that apparently features improved access to these services, but Tidal / Qobuz were never incorporated into Linn’s Kinsky control point.

As regards to Moode, if I get it right, access to these services is principally provided via upmpdcli, which is still actively being developed. Currently, Moode utilises version 1.2.16 of this component which came out circa two years ago and in many respects is OK, but various tweaks have since been made that IMHO have radically enhanced the capabilities of upmpdcli - including support for OpenHome Credentials service, which seemingly allows access to both Qobuz and Tidal directly from Kazoo.  

Personally, I’ve never used either Qobuz or Tidal so I’m not going to put my neck on the block by saying upgrading upmpdcli may resolve this particular issue (and incidentally upmpdcli is now at version 1.4.7), but in my reckoning it’s definitely worth trying.   Good luck with getting to bottom of this!
Reply
#7
Davaar is the firmware stack that runs on native Linn Digital Stream (DS) systems. These incorporate direct support for Tidal and Qobuz which Kazoo leverages. Moode is not running the full openhome stack and so does not fully support Tidal and Qobuz using the same mechanism. Kazoo not realising it's not talking to a Linn DS, thinks it's running a down-level version fo Davaar and thus recommends upgrading.

The Upmpdcli documentation says from v1.3 it does support Tidal using Kazoo but something has changed - I believe v6.5/v6.5.1 is still running Upmpdcli v1.2.16 (not had time to upgrade yet).
Reply
#8
Thanks for the explications about Davaar.

Several posters have kept us well aware of the nice enhancements constantly being added to the upmpdcli release notes. Whether any of them will resolve the OP's issue is unknowable without testing. 

I can't speak for Tim but I seem to recall that upmpdcli v1.3 and beyond is not a simple drop-in replacement for the v1.2.6 currently in use. Could be wrong. I'm sure the update is somewhere on the endless TODO list.

Let's not open a discussion of UPnP/DLNA vs OpenHome. Let the update occur first and then we'll see.

Regards,
Kent
Reply
#9
(04-29-2020, 02:57 PM)SoundAdikt Wrote: ... The Upmpdcli documentation says from v1.3 it does support Tidal using Kazoo but something has changed - I believe v6.5/v6.5.1 is still running Upmpdcli v1.2.16 (not had time to upgrade yet).

I suggest you upgrade upmpdcli to the lastest version, test it, and if your issue still persits contact its developer, who in my reckoning provides excellent support - https://framagit.org/medoc92. Incidentially, I upgraded to the latest version of upmpdcli without issue on Moode v6.4.
Reply
#10
(04-29-2020, 03:59 PM)Zigzag Wrote: Incidentially, I upgraded to the latest version of upmpdcli without issue on Moode v6.4.

Ah. Thanks for that. So much for my faulty memory.

Regards,
kent
Reply


Forum Jump: