Thank you for your donation!


Disable BLuetooth from SSH
#1
So, I tried enabling bluetooth. 
I first enabled the bluetooth device in system, then rebooted. After reboot I guess I got confused and enabled it in Audio config. Moode then froze up and I can't access it, except through ssh.  Is there a way to disable this setting from ssh, or am I hosed? 

Thanks in advance.
Reply
#2
Which model Pi?
Reply
#3
(05-18-2020, 09:05 PM)Tim Curtis Wrote: Which model Pi?

3b+ 
Moode 6.4.2
Reply
#4
Bluetooth adapter is on by default. You have to explicitly turn it off in System Config. In Audio Config there is the warning below the Bluetooth ON/OFF option.

"WARNING: A Bluetooth adapter must be physically attached and enabled before turning this ON otherwise moOde startup will fail."

Via ssh run the sql command below and reboot. This turns off the Bluetooth service.

Code:
sqlite3 /var/local/www/db/moode-sqlite3.db "update cfg_system set value='0' where param='btsvc'"
Reply
#5
(05-18-2020, 10:25 PM)Tim Curtis Wrote: Bluetooth adapter is on by default. You have to explicitly turn it off in System Config. In Audio Config there is the warning below the Bluetooth ON/OFF option.

"WARNING: A Bluetooth adapter must be physically attached and enabled before turning this ON otherwise moOde startup will fail."

Via ssh run the sql command below and reboot. This turns off the Bluetooth service.

Code:
sqlite3 /var/local/www/db/moode-sqlite3.db "update cfg_system set value='0' where param='btsvc'"

Thanks Tim, I took the opportunity to just move to 6.5.2. I'll mark this down in case I run into again. 

Just for future reference where did I go wrong in enabling bluetooth? Is the bluetooth renderer in Audio settings meant for something else? If so, how do I go about pairing my phone?

With the move from Google Play Music to Youtube Music, I'm trying to figure out my streaming options for those services moving forward. I've seen you say you use bluetooth, so I'd thought I'd give it a try too.
Reply
#6
After turning on Bluetooth in Audio Config, turn on the Paring agent. Then on your phone's Bluetooth list of devices connect to Moode Bluetooth.

I mostly use Airplay cos my devices are Apple. I use Bluetooth to stream to an Anker speaker.
Reply


Forum Jump: