Thank you for your donation!


Problem: Audiophonics PI-SPEC V2 power management module scripts
#1
Hello,

I recently bought this PI-SPC V2 Power Management Module and I`m trying to make it work. I have Pi4 with Audiophonics I-Sabre 9038Q2M DAC. Audiophonics claim they don`t support this module when it comes to Moode and I can`t find any scripts designed for it.

I will be grateful for any help,
jackobtone
Reply
#2
That module seems a costly way of doing something you can already do for nearly free...
These links walk through a safe power button and led indicators...

https://howchoo.com/g/mwnlytk3zmm/how-to...spberry-pi
https://howchoo.com/g/ytzjyzy4m2e/build-...-indicator
Reply
#3
@jackobtone - Just ask Audiophonics for a download link to any Raspbian based script for this device and then maybe someone on the Forum here will help modify it for moOde.
Reply
#4
(05-19-2020, 11:09 PM)DRONE7 Wrote: That module seems a costly way of doing something you can already do for nearly free...
These links walk through a safe power button and led indicators...

https://howchoo.com/g/mwnlytk3zmm/how-to...spberry-pi
https://howchoo.com/g/ytzjyzy4m2e/build-...-indicator

I wish I found those tutorials before I bought this Audiophonics module :/


Here are two links posted by Audiophonics with instructions how to install scripts for other OS, but unfortunately they seem to be innactive… (they were active a few days ago - Audiophonics forum seems to be dead). I also found something like this: link Maybe it will be helpful.

Edit: 
Turning on works well - led indicator in the button blinks correctly, blue led on the Audiophonics board meaning "boot ok" shines, system starts, led indicator in the button starts shining constantly
SoftShutdown doesn`t work - system doesn`t shutdwon, but Audiophonics cuts the power after some time anyway
HardShutdwon doesn`t work as it should - power isn`t cut immediately, only when i hold the buton for a few sec.
What is more something is wrong with the pinouts, I mean all I wrote above works when the order of connection to gpio is defferent from what is specified by the manufacturer

Thank You very much for replies!
Reply
#5
I`ve emailed Audiophonics and received two link as bellow:

https://github.com/audiophonics/Raspberr...management

https://www.audiophonics.fr/fr/blog-diy-...guree.html - This is as they say ready to use software, but based on older version of moOde. What is more some things doesn`t work properly there, or maybe it`s because of my second SD card.
Reply


Forum Jump: