Thank you for your donation!

Problem: How to use GPIO button handler
Hello everybody,

I have a question concerning the use of the "GPIO button handler" function. My problem is, there seems to be no reaction when I trigger one of the GPIOs...
My setup is:
Raspbery Pi 4
Moode Audio 6.5.1 and 6.5.2 (I tried it with both)
Button 1     ON     PIN 10      CMD     mpc next

When I enter mpc next into the Web SSH terminal the music jumps to the next track.
I measure 3.3V on GPIO10.
When I connect GPIO10 with a 4,2kOhm resistor to ground, the voltage drops to 0.25V but I get no reaction.

I also tried it with Pin 10 on the Pi which is GPIO15, but again nothing happend.

Do I have to make something else to make this work? Like activating a script maybe?
Any help would be much appreciated. I am having a lot of fun with this wonderful piece of software and would like to make it more usable for my family :)

Under the SAVE button

NOTE: Use a comma to delimit arguments in the CMD field. Example: mpc,load,My Playlist
The comma did the trick. Thank you very much! Smile

Forum Jump: