Thank you for your donation!


Solved: No spotify as renderer
#1
On a newly installed moOde (6.5.2) I don't get Spotify as a renderer in Audio options.

Any idea on how to check what's wrong?
Reply
#2
Looks like I found the culprit: there's something wrong with librespot executable. Trying to start it manually I get segmentation fault.
Reply
#3
What model Pi?
Are u using stock moOde 6.5.2 from moodeaudio.org or did it come from some other source?
Reply
#4
@Tim Curtis:
Code:
# cat /proc/cpuinfo | grep Model
Model           : Raspberry Pi Model B Rev 2
Reply
#5
(06-22-2020, 01:23 PM)radu- Wrote: @Tim Curtis:
Code:
# cat /proc/cpuinfo | grep Model
Model           : Raspberry Pi Model B Rev 2

I haven't had any original model B's in years but I just fired up an RPi ZeroW which has essentially the same specifications vis-a-vis ARMv6Z, BCM2835, etc.

Librespot enabled without issue in moOde 6.5.2 and the Spotify app on my iPad had no trouble finding and connecting to it.

I suggest you reflash the moOde image.

Regards,
Kent
Reply
#6
Yes. I'm doing this just now. I had a 6.5.0 image wich I used and then updated it to 6.5.2 from the interface.

I'll update the status once I boot the new image.
Reply
#7
Using 6.5.2 image fixed it. Thanks for the heads-up @TheOldPresbyope!
Reply
#8
For what its worth, I just had the same thing happen. Perfectly working otherwise 6.5.2 on a Pi Zero W, supposedly good quality SD card, Samsung Evo. Found the Spotify renderer option was missing from the Audio config page. Tried to run librespot from the cli, got a segfault. Reflashed and all is well.

Could there be a librespot binary or lib or config file thats getting regularly corrupted here? Pure coincidence?
Reply


Forum Jump: