Thank you for your donation!


Problem: Missing artists... bad folder names?
#11
(07-11-2020, 03:28 PM)Tim Curtis Wrote: The OS X shell might be a bit different than RaspiOS shell and thus the weirdness with trailing dot.

Btw, below are lines from moOde smb.conf to deal with some of those those annoying OS X dot files.

veto files = /._*/.DS_Store/
delete veto files = yes

Just to be sure I set mpd logging to verbose and the regenerated my music library. The resulting log appears to have output lines for each folder encountered. But it did not log anything for folders with trailing periods. To me that seems like an issue with the CIFS implementation (I don't mean bug), not an issue with MPD or moOde.

Anyway, it's probably not worth chasing down, I've got a workaround, and hopefully anyone else missing their R.E.M. or Run-D.M.C. albums will find this thread. Smile 

Thanks again for the responses!
Reply
#12
BTW - just donated to moOde via PayPal. Thanks for al the hard work!
Reply
#13
My NAS is connected through NFS and I do have a folder "R.E.M" that is visible in the artists list.
Initially, I had the same problem that the folder "R.E.M." was not visible in the folders view, but that did change after I did set the library options to UTF8 character filter = "Yes".


Within my "R.E.M" folder, some albums are tagged as "R.E.M." and others just as "REM". Consequently, some albums appear in the "R.E.M" and others in the "REM" artist view of moode.

Try to change the UTF8 character filter.
Reply


Forum Jump: