Thank you for your donation!


Muting the signal
#1
RPI 3B+, Moode 6.7.1, Schiit Modius

Is there a way to mute the audio signal momentarily when switching between sources (radio station, tracks, etc.). I get a strong, high frequency modulation that lasts for up to a couple of seconds when I switch between sources, for instance if I switch radio stations or from radio to albums. I experience similar but briefer modulation when I switch tracks in an album. I do not have resampling set. The USB Source lists the Modius correctly.

Thanks in advance for any help.
Reply
#2
Don't think muting the source will do anything, that sounds like audible DAC jitter which no DAC worth it's salt should be emitting when switching bit depths & sample rates. The DAC should do the switch seamlessly, there are other threads on this forum discussing noisy DACs.
As in other threads discussing jitter noise, if your DAC is making such noises generally the only way to avoid that is to resample everything to the DAC's native/maximum bit depth and sample.rate so it doesn't have to switch between these sample rates or shop for a different DAC.
Reply
#3
(07-24-2020, 09:20 PM)vinnn Wrote: Dont think muting the source will do anything, that sounds like the dreaded audible DAC jitter which no DAC worth it's salt should be emitting when switching bit depths & sample rates. The DAC should do the switch seamlessly.
As in other threads discussing jitter noise, if your DAC is making such noises generally the only way to avoid that is to resample everything to the DAC's native/maximum bit depth and sample.rate so it doesn't have to switch between these sample.rates or shop for a different DAC.

Thanks for the reply. I did try switching the resampling to 16 and then 24 bits, no improvement. I guess I'll look at another DAC. Cheers!
Reply
#4
(07-24-2020, 09:24 PM)Geojanitor Wrote: Thanks for the reply. I did try switching the resampling to 16 and then 24 bits, no improvement. I guess I'll look at another DAC. Cheers!

What kind of USB cable you using? Is it s particularly cheap & nasty USB cable or is it the one you got with the Schiit? Believe it or not this can affect clock sync and jitter.
Reply
#5
This symptom "I get a strong, high frequency modulation that lasts for up to a couple of seconds when I switch between sources" suggests some sort of hardware issue, especially since it lasts 2 seconds :-0
Reply
#6
OK well clock jitter bursts are normally much shorter than a couple of seconds but I think I know what you mean, I had a similar problem with one of my portable DACs, the Cyrus Soundkey which turned out to be a driver problem. Like a raspy tearing sound.

Try enabling the USB UAC2 fix option in Moode's system settings and ensure your USB cable is at least USB2 rated as recommended on Schiit's website here.
Reply
#7
And, of course, one could resort to asking Schiit: info@schiit.com[url=info@schiit.com][/url]
Reply
#8
(07-24-2020, 10:21 PM)TheOldPresbyope Wrote: And, of course, one could resort to asking Schiit: info@schiit.com[url=info@schiit.com][/url]

I've tried a number of cables, but I am not sure any are USB 2.0 approved, so I will venture out to buy a new one that is. I have reached out the Schiit and they have no ideas what is going on but have suggested I try a different digital source. So I will buy a coax cable at the same time to see if a digital signal from a CD player into the DAC has the same issues. Meanwhile, I tried a version of Volumio to see if it was a software issue. It seems to have a bit of a lag in switching radio stations so the buzz is not apparent using it. However, I do not like Volumio much and rather stick with Moode. I notice in the ALSA documentation that there is a parameter called buffer_before_play, could this be the difference between the two players?
Reply


Forum Jump: