Thank you for your donation!


Problem: Unresponsive with Bluetooth
#1
Good day all.  I just installed moode in an attempt to replace Volumio.  Running a Pi3 with a HIFI Berry Amp.  Was able to get initial setup working, playing audio fine, airplay enabled, etc.  Then when I tried to turn on bluetooth, I could no longer access the system web or airplay.  Doesn't show up as a bluetooth device either.  I can ssh into it.    If I run moodeutl -A rm 16384 and then moodeutil -r everything works again.  If I renenable moodeutil -A add 16384 it breaks again.

Any advice on how to get bluetooth working?
Reply
#2
When breakage occurs look at the Moode log. If the log stops at the line where Bluetooth attempts to start it usually means that Linux has not detected the presence of a Bluetooth adapter or the adapter is present but not enabled i.e. it's been disabled either via moOde System Config or by some hack to /boot/config.txt.
Reply
#3
(07-29-2020, 03:28 PM)Tim Curtis Wrote: When breakage occurs look at the Moode log. If the log stops at the line where Bluetooth attempts to start it usually means that Linux has not detected the presence of a Bluetooth adapter or the adapter is present but not enabled i.e. it's been disabled either via moOde System Config or by some hack to /boot/config.txt.

20200729 103223 worker: -- Feature availability
20200729 103223 worker: Source select (available)
20200729 103223 worker: Source select (source: MPD)
20200729 103223 worker: Source select (output: HiFiBerry Amp(Amp+))
20200729 103223 worker: Bluetooth (available)
20200729 103223 worker: Bluetooth (started)

That is where the log ends.

This was built of a virgin install from the moode image, only config changes were made in the moode config gui.

Is it possible the bluetooth conflicts with the hifiberry amp?
Reply
#4
Dunno, I don't have one of those devices.

config.txt should have the two lines below

#dtoverlay=disable-wifi
#dtoverlay=disable-bt
Reply
#5
(07-29-2020, 03:46 PM)Tim Curtis Wrote: Dunno, I don't have one of those devices.

config.txt should have the two lines below

#dtoverlay=disable-wifi
#dtoverlay=disable-bt

I figured it out.... chalk this one up to user stupidity.  I set up a second pi with a virgin image and reconfigured.  Everything was working as I expected on the spare pi (no HifiBerry Amp).  Moved the card to the pi with HifiBerry amp and booted to configure the hifiberry amp and the issue followed.  So the problem was the pi, not the software.  Went to swap the pi out with the one that worked and discovered my stupidity.... it was a Pi2, no bluetooth on board. DOH!  Swapped in the Pi3 and everything is now 100% a-ok.
Reply
#6
lol, Ive done that b4 :-0
Reply


Forum Jump: