Thank you for your donation!


Whole Library Shuffle
#1
Is there any easy way to shuffle the whole library without creating a giant playlist? Every time I want to shuffle my whole library, I navigate to the Music Folder on my NAS and hit play, then enable shuffle. This method unfortunately locks things up as I have a decent sized library and it is a lot of data to add to a playlist at once. 

Thanks in advance!
Reply
#2
have you tried turning on auto-shuffle in settings ?
M - Configure - Audio - Auto-Shuffle on
Play Music (1 Track in Playlist)
Hit the random button

When the last song in the Playlist has finished playing, Auto-shuffle adds two randomly selected songs from the music library to the end of the Playlist then repeats the process. This creates a continuous stream of music without growing the Playlist and having two tracks enables MPD Crossfade to be used. NOTE: Auto-shuffle replaces MPD random play as the method for the 'Random' button.
Reply
#3
I have had the same issue for several versions of moOde. According to Tim (moOde developer) it is a resource issue. My music folder is on a synology DS415 play and there are over 2,600 albums which takes a significant to update.  I have had tried this feature on a much smaller music folder also on the NAS and it worked just fine. Thanks
Reply
#4
(08-04-2020, 11:51 AM)fritschomat Wrote: have you tried turning on auto-shuffle in settings ?
M - Configure - Audio - Auto-Shuffle on
Play Music (1 Track in Playlist)
Hit the random button

When the last song in the Playlist has finished playing, Auto-shuffle adds two randomly selected songs from the music library to the end of the Playlist then repeats the process. This creates a continuous stream of music without growing the Playlist and having two tracks enables MPD Crossfade to be used. NOTE: Auto-shuffle replaces MPD random play as the method for the 'Random' button.

I played with this this weekend and it wouldn't work. I created a playlist with one song, and after that song no further music would play with the autoshuffle turned on. Not sure if it's a bug or if I have it configured wrong, or it won't work with music stored on a server. Perhaps it only works with locally stored music. Not sure, but it's kind of a bummer to not be able to turn on auto shuffle with a whole library without it bogging the system completely down.
Reply
#5
It doesn't matter what's already in the playlist. To activate Auto-shuffle random play do the following:

1. Menu, Audio config
2. Turn Auto-shuffle ON
3. Return to Playback panel
4. Stop playback
5. Click the Random button underneath the volume knob

2 tracks should be automatically added to the playlist and the first of the two tracks should start playing.
Reply


Forum Jump: