Thank you for your donation!


Solved: NAS hosted albums not showing in Library
#1
Hi,

I have a problem where my NAS hosted albums are not showing in the Library.  I'm not sure if I'm doing something wrong in moOde or if it's a problem with my NAS.  I'm using OpenMediaVault on a Raspberry Pi 4 for my NAS and, apart from this, all is OK with it.

1. I add a music source and map the appropriate drive from my NAS.  * note that scanning doesn't 'see' my SMB shares so I added the path manually.

[Image: 50281744563_26204763f9_c.jpg]

2. Save that and the source shows a green tick.  Then click Regenerate to regenerate music library.  You can see below that 47 albums are processed.

[Image: 50282425206_2576aae50a_c.jpg]

3. From the Library screen, select from the menu Update Library.  I get a Library updating message but afterwards I can't see my NAS in folder view or any of my albums.

[Image: 50282585217_8cba16bc5e_w.jpg]



I suspect it's something to do with my OMV NAS but everything else seems to be OK with that, I can see shares on my PC.  But when I add a connection and regenerate library, it 'finds' 47 albums - so why can I not see them in the Library?

I'm not really sure where to look for logs but a moodeutl -s shows this -

[Image: 50281808038_0ea9c42430_w.jpg]

Can anyone help with this as it's driving me mad!

Thanks,

Matt
Reply
#2
Try setting your mount flag to vers=1.0, I run a OMV NAS on a pi 4 and that's what mine is set to.
Reply
#3
Thanks - I've tried that but still get the same problem.  I'll have a search of the forum but I wonder if my problem may be at the OMV end.

From another thread on here I've seen to issue the command  smbtree -b -N to view available samba shares.

I get:


pi@moode:~ $ smbtree -b -N

Unable to initialize messaging context
smbXcli_negprot_smb1_done: No compatible protocol selected by server.
smbXcli_negprot_smb1_done: No compatible protocol selected by server.
pi@moode:~ $

So I'm thinking that may be where the problem is.  Still not sure how the library rebuild can work - or appear to work  Confused

Do you get some available OMV shares if you issue that command?
Reply
#4
Menu, Update library then look in MPD log for errors

Code:
cat /var/log/mpd/log
Reply
#5
A good guide to setting up OMV on a pi.

https://thepi.io/how-to-use-your-raspber...a-nas-box/
Reply
#6
(08-29-2020, 06:51 PM)Tim Curtis Wrote: Menu, Update library then look in MPD log for errors

Code:
cat /var/log/mpd/log

Thanks - output as below.  So is that a permissions issue on my NAS despite me entering the correct NAS userid/password (and then trying to make the share public)?

pi@moode:~ $ cat /var/log/mpd/log

Aug 29 15:38 : update: updating SDCARD/Stereo Test/LRMonoPhase4.flac
Aug 29 15:38 : exception: Failed to open /var/lib/mpd/music/NAS/OMVNAS: Permission denied
Aug 29 15:39 : exception: Failed to open /var/lib/mpd/music/NAS/OMVNAS: Permission denied
Aug 29 15:42 : update: updating SDCARD/Stereo Test/LRMonoPhase4.flac
Aug 29 15:42 : exception: Failed to open /var/lib/mpd/music/NAS/OMVNAS: Permission denied
Aug 29 15:42 : exception: Failed to open /var/lib/mpd/music/NAS/OMVNAS: Permission denied
Reply
#7
(08-29-2020, 06:59 PM)kit1cat Wrote: A good guide to setting up OMV on a pi.

https://thepi.io/how-to-use-your-raspber...a-nas-box/

Thanks for this.  I reckon I'm mostly there with OMV.  It's been running for a while OK with everything including DLNA server, samba shares (that work ok with Windows 10), and Docker all working well.  I think maybe I've stuffed up the security despite only having one user - 'pi'.

I'll carry on investigating!
Reply
#8
@mattdav

Quote:I think maybe I've stuffed up the security

There's no maybe about it Tongue

In your defense, the OpenMediaVault documentation is almost has hard to decypher as Synology documentation. One confusing point is the difference between the permission settings under Access Rights Management and the permission settings under Services. Without the docs at my fingertips ATM I'm not going to attempt an explanation. See the Wiki.

However, if you go to the OpenMediaVault UI and navigate to Services>SMB/CIFS>Shares you should be able to set, on a share by share basis, who is allowed access to a share (like are guests allowed) and what they can do (like browse, read-only, etc). Since my server is behind a firewall I allow guest access with no restriction and the moOde setup is trivial. It's just as easy to restrict access in various ways and I've done it in the past to make sure it works but it may take some incrementing and testing to get you what you want.

The SMB protocol level is pretty much a non-issue with OpenMediaVault. Out of the box it allows connection using v1.0, v2.0, and v3.0. Only if you futz with the "Extra options" will this change.

Regards,
Kent
Reply
#9
Right - I've sorted it!

As suspected and suggested, I'd somehow stuffed the permissions in OMV - so nothing at all to do with moOde.

For reference, I added the 'resetperms' plugin in OMV which allowed me to reset the permissions on my share.  Once I'd reset the permissions, I went back into moOde and everything works like a dream.

Thanks everyone for helping me to solve a problem of my own making! Big Grin

Matt
Reply
#10
@mattdav

Nice.

I haven’t paid much attention to the OMV plugins. That one sounds very handy for extricating oneself from the permissions maze. Thanks for mentioning it.

Regards,
Kent
Reply


Forum Jump: