Thank you for your donation!


NAS library update/access problem
#1
Hello,

I am using moOde for long time. On a living room player I'm using release: 3.1 2016-12-05 with great success. The audio library is fairly large. On OMV. I'm running moOde on RPI 3

Now, I try to install another player, but I get crazy now. I have a small share with a few albums, that is scanned and showed fine. On the other hand the big library is not updated right.
It starts to update, scans for a while but than it stops. Than I can see the NAS under Library for a moment, with small portion of the albums, but than that disappears also.

In the MB long logfile /var/log/mpd/log , the first line is (cleared before update) 
Sep 03 22:04 : update: added NAS/zene/.....

The last line is similar, but on another file. I do not find any error in between.

I have removed shares, recreated several time, sometime it appears in the library for a while, sometime it does not even appear there.

Do you have an idea how to debug further?

Thanks a lot,
JG
Reply
#2
I keep playing with it.

I found now, during update, the NAS share is listed under the library and I can browse it. When the update finishes, the share disappears from under the library.

Initially I have tried with a read only login to NAS (which works fine with release: 3.1), now I created it with r/w user, but it did not change anything :-((

JG
Reply
#3
Hello,
Please help. I was playing with it until 3AM :-), but I could not step forward. I really need this to work. 
Any idea?
I have borrowed a 3T external hdd. Can I attach directly if I format it to ext4 ?
Just to find out if the promblem is in the library size or network related.
Thanks
JG
Reply
#4
It'll disappear if there's no content in the directory, more specifically if there was no metadata imported into the library from that path.

Just saying something doesn't work doesn't help anyone understand your problem or how you've configured your system.
A good start would be to let us know what kind of share is it, is it an SMB/CIFS share or an NFS export or something else?

As you've logged onto the Pi in order to look at the mpd log, have you looked to see if the share is mounted and you can see files in there? e.g.  

Code:
df -h
find /mnt

The above df command will show you a list of mounted filesystems, the find command should show you a recursive list of everything under /mnt
Reply
#5
Thank You for your reply!

Just before I saw your reply, I have reflashed now again, now to a 16G card, I was thinking is the 8G card is too small. (I know it should be plenty, but I started before I saw your reply, so now I test it also).
At least, there is again a clean install. I did not change anything, only added the library, updating now.
(By the way, can I do "sudo apt-get update" and "sudo apt-get upgrade" ?, or that is not recommended? Last night I did and it did upgraded a lot, but did not help.)

It seems the card size solved the problem! Interesting, because I think there was plenty of space on the previous card also. Anyway, now I update the library for one hour and it is still running, while before the update was 5 min. The mpd log was always started and ended with the same file, and the lenght of the logfile was 1M. Now it is 6M already and keep updating :- )))))

I did checked the mount before, it is the same. With
the df -h shows this :

pi@moode:~ $ df -h
Filesystem           Size  Used Avail Use% Mounted on
/dev/root            3.4G  2.6G  589M  82% /
devtmpfs             901M     0  901M   0% /dev
tmpfs                934M     0  934M   0% /dev/shm
tmpfs                934M   18M  917M   2% /run
tmpfs                5.0M  4.0K  5.0M   1% /run/lock
tmpfs                934M     0  934M   0% /sys/fs/cgroup
/dev/mmcblk0p1       253M   55M  198M  22% /boot
//192.168.2.21/zene  5.5T  2.7T  2.8T  49% /mnt/NAS/zene
tmpfs                187M     0  187M   0% /run/user/1000
it is exactly as it was with the previous card.

I did not listed the with "find /mnt" before, it is throwing all the files now, I can not copy here. Starting with this :


pi@moode:~ $ find /mnt
/mnt
/mnt/SDCARD
/mnt/SDCARD/Stereo Test
/mnt/SDCARD/Stereo Test/LRMonoPhase4.flac
/mnt/NAS
/mnt/NAS/zene
/mnt/NAS/zene/Ten Years After
...

So, I hope the card size solved it :-))
Both cards are Kingston middle speed cards (not the top one for UDH cameras, but not a slow one either.)

Thanks,
JG
Reply
#6
There is another difference.
Before I did expanded the file system. Now I did not yet, now I forgot it and it works. Now I do not have much space, but I had more before.
That is strange, it is probably not space, but I'm not sure what it is now.
Reply
#7
The update finished and I can see all now.

I'm curious now, unfortunately I did overwrite the 8G card, but I may reflash it to see.

Last night I did a few times, I did almost everything the same way, except the expansion after the first boot.

I have some other question, but it is a different topic.

Regards,
JG
Reply


Forum Jump: