Thank you for your donation!


HDMI Output no audio
#1
Hello,

Fresh member, fresh installation and fresh problem.
I deployed moode-r671 in my RPi3 on a 16GB sdcard. The setup is RPi3 (HDMI) -> AVR (Denon x5200)
I setup HDMI output in MPD settings.
However no audio comes out of the system. Also (if it matters, not sure what output I should expect) the screen goes completely blank after the boot sequence.
Lastly, the only error I can see in dmesg is:
Code:
[    8.252392] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt failed with error -2

Any ideas?
Reply
#2
Just to check..you downloaded the pre-built image for 6.7.1, burnt it to your sd card, booted your Pi from it and logged into the MoOde web page from another device. You used the System Configuration tab to select Local Display and the Audio Configuration tab to select the HDMI audio, saved selections in both pages, then rebooted. ?
I am a professional finder with the memory of an elephant.... a curse but a useful curse :-)
Reply
#3
Thx! That appears to have been the problem! It seems to be working now - or at least I get audio out of the HDMI! Perhaps it should be added to the wiki (or is my setup that uncommon?)

The next question now is: why is it only playing stereo? Even when fed with multichannel audio (flac, 96000:24:6) it plays it in stereo mode!
Reply
#4
(09-11-2020, 05:10 PM)eloydark Wrote: Thx! That appears to have been the problem! It seems to be working now....................... snip ..................

...so what you did not do off @Drone7's list of DOs that solved your problem...?

If the issue has been solved then the thread needs to be set to [SOLVED], if you don't mind...
Reply
#5
Apparently I had not set System Configuration -> Local Display.
How does one set the thread to [SOLVED]? Or is it just manually editing the thread name?

Any recommendation on multichannel audio? Or is it just not supported?
Reply
#6
Multichannel passthrough is supported. There was one other user that was doing it but had to add the param below to /boot/config.txt. This param is already in moOde 6.7.1 so I'm not sure why its not working for you.

# Pretend all audio formats are supported by display, allowing passthrough of DTS/AC3 even when not reported as supported.
hdmi_force_edid_audio=1

Edit your OP (posts #1) and mark it as SOLVED.
Reply
#7
Note that hdmi_force_edid_audio=1 will allow DTS/ac3 passthrough which are compressed 5.1 channel formats.

(flac, 96000:24:6) will not work on the rpi HDMI as the kernel is configured in Raspberry Pi OS.

Code:
alsacap
*** Scanning for playback devices ***
Card 0, ID `b1', name `bcm2835 HDMI 1'
  Device 0, ID `bcm2835 HDMI 1', name `bcm2835 HDMI 1', 4 subdevices (3 available)
    1..2 channels, sampling rate 8000..192000 Hz
    Sample formats: U8, S16_LE

The bcm2835 kernel module is compiled to only support 8/16 bit depth 2 channel audio. If Moode builds its own kernel (or kernel modules) it would be great if the bcm2835 driver was built with 8 channel and 24/32 bit support. Some other distributions such as picoreplayer do this.
Reply


Forum Jump: