Thank you for your donation!


Official moOde 7.0.0 subthread [Plugins] (e.g. UPNP)
#51
(01-19-2021, 05:50 PM)TheOldPresbyope Wrote:
(01-19-2021, 04:32 PM)zOr7gA8 Wrote:
(01-17-2021, 09:48 PM)Tim Curtis Wrote: Right, you'll need

1. The recipe to build and install libupnpp-bindings-0.20.1
2. /var/www/command/upnp_albumart.py
3. /var/www/inc/playerlib.php

Optionally the recipe to build and install upmpdcli 1.5.8

can' test this. with files for 2. and 3. taken out of git (moode-develop) I get an mpd error. no playback.

I'm away from my test system so can't comment on details.

In general, it's a bad idea to cherrypick important system files like playerlib.php from the github develop branch. It may contain many commits since the last release, one or more of which may be pertinent to this specific issue but also others which are not pertinent but which depend on commits made to other files too.

When I tested the upnp_albumart.py script I edited only the line in my working playerlib.php which invoked the previous script, upexplorer.

Regards,
Kent

good tip. found what I have to change and kept the original file.
can report later.
Reply
#52
it works!!!!! woooohoooo! (pic attached)
cover is there with usage of bubble_upnp without restarting upnp-renderer ;-)))

actual test-system is:

1) moode 7.0.1 image - with following additions:
2) build libupnpp-0.20.2 with build-recipe.
2.1) build upmpdcli-1.5.8 with build-recipe.
3) build libupnpp-bindings-0.20.1 with build-recipe.
4) added <upnp_albumart.py> from github - moode-develop to /var/www/command
     https://github.com/moode-player/moode
5) modified <playerlib.php>
    for script-usage as told at:
    https://github.com/moode-player/moode/co...aa2b47c8dd
thanks Tim & Kent.


Attached Files Thumbnail(s)
   
Reply
#53
I really need this, but I'm completely incapable of doing all this, it's too much for me low level of programming, I'll have to wait for the next version to include it, while I get back to v6. 7.1

Good job.
Reply
#54
(01-22-2021, 05:08 PM)Edues Wrote: I really need this, but I'm completely incapable of doing all this, it's too much for me low level of programming, I'll have to wait for the next version to include it, while I get back to v6. 7.1

Good job.

at least it is "only" a complex way of copy-paste. and you can learn a lot while working through steps.
but. not for everybody.
I think you don't have to wait this long ;-)

I also used 6.7 the last weeks.
Reply
#55
(01-22-2021, 05:25 PM)zOr7gA8 Wrote:
(01-22-2021, 05:08 PM)Edues Wrote: I really need this, but I'm completely incapable of doing all this, it's too much for me low level of programming, I'll have to wait for the next version to include it, while I get back to v6. 7.1

Good job.

at least it is "only" a complex way of copy-paste. and you can learn a lot while working through steps.
but. not for everybody.
I think you don't have to wait this long ;-)

I also used 6.7 the last weeks.

Thanks zOr7gA8 for your help, 
I have tested the updated image with MPD 1.5.8, and I confirm that all the problems with BubbleUpnP have been solved.

In fact it works better than ever, the interface on the smartphone updates instantly, on the Moode tft monitor too, covers, volume, any update is quickly reflected on both interfaces, if I have a browser open from Windows, it also works just as well.

The only exception is the volume displayed in the browser, both on the local monitor, as in Chrome from Windows, the volume suffers from a latency that makes it almost useless, but this also happens with the encoder I have installed, if I trigger the encoder volume changes are instantaneous in Bubble and audio output, not so in the browser, which does not reflect them, or does so erroneously, but with this you can live perfectly, it seems more a problem of Chrome.

Thanks again for your help zOr7gA8, I hope to repay in some way the impeccable support of this community, which confirms the exceptionality of Moode in all its areas.

Edues
Reply
#56
(01-24-2021, 11:19 AM)Edues Wrote:
(01-22-2021, 05:25 PM)zOr7gA8 Wrote:
(01-22-2021, 05:08 PM)Edues Wrote: I really need this, but I'm completely incapable of doing all this, it's too much for me low level of programming, I'll have to wait for the next version to include it, while I get back to v6. 7.1

Good job.

at least it is "only" a complex way of copy-paste. and you can learn a lot while working through steps.
but. not for everybody.
I think you don't have to wait this long ;-)

I also used 6.7 the last weeks.

Thanks zOr7gA8 for your help, 
I have tested the updated image with MPD 1.5.8, and I confirm that all the problems with BubbleUpnP have been solved.

In fact it works better than ever, the interface on the smartphone updates instantly, on the Moode tft monitor too, covers, volume, any update is quickly reflected on both interfaces, if I have a browser open from Windows, it also works just as well.

The only exception is the volume displayed in the browser, both on the local monitor, as in Chrome from Windows, the volume suffers from a latency that makes it almost useless, but this also happens with the encoder I have installed, if I trigger the encoder volume changes are instantaneous in Bubble and audio output, not so in the browser, which does not reflect them, or does so erroneously, but with this you can live perfectly, it seems more a problem of Chrome.

Thanks again for your help zOr7gA8, I hope to repay in some way the impeccable support of this community, which confirms the exceptionality of Moode in all its areas.

Edues

Nice to hear and was a pleasure to me helping out.

Chrome isn't working well with moode 7. For this I switched back to Friefox. The latency issue is mentioned in the main thread for support I think. But since I have volume control disabled I'm not into this.

regards, Martin
Reply
#57
(01-10-2021, 09:09 PM)maosojam Wrote: Hi guys! A pleasure to be here.

In first place, thanks so much for really good work with Moode.

I have been a moodle user since mid 2020. Recently, I updated Moode to 7.0.1 version on my Raspberry Pi 4 Model B with Allo Digione Signature like hat. After updating I have not been able to connect to the UPNP Moodle server with Linn Kazoo remote control (last version 4.13.74) on my MacBook. UPNP working fine on IOS device using mconnectLite APP.

Let me know if I can support you with some more information or whatever, I'm a PHP developer.

Regards,
Maximiliano.

Hi,

Sorry guys I have not checked here, neither I have not received email notification of thread updates, I have to check out this config in My Account (I already found here in the option "Thread Subscription").
I like to see that there is an active community here. I'd like to learn, I've already been trying to follow the comments, and reading some code in the Moode and upmpdcli repositories. I don't know Python, and since college I don't use c ++.

About my question, Tim's suggestions were the solution. Also I tested with UPnP A / V services turned on, Kazoo seems to work fine for playing my audio files using Moode DLNA.
On john's question, if I would love to be able to use Tidal over Linn Kazoo on my MAC, I currently have it set up configured and I see the option "Tidal" in the Moode UPNP tab, but when trying "My Music", " Genres "or wharever, it always appears the same" Service login or communication failure" message.

Thanks so much to both!

Regards,
Maximiliano.
[color=#888888][size=small][font=Arial, Helvetica, sans-serif][i][size=medium][font=arial, helvetica, sans-serif]Maximiliano Ariel Osorio[/font][/size][/i][/font][/size][/color]

Reply
#58
Thanks for the info. It seems like the libupnpp-bindings will solve the "playlist advancing" problem I have experienced with BubbleUPNP control point.
Reply
#59
(01-20-2021, 12:36 AM)zOr7gA8 Wrote: it works!!!!! woooohoooo! (pic attached)
cover is there with usage of bubble_upnp without restarting upnp-renderer ;-)))

actual test-system is:

1) moode 7.0.1 image - with following additions:
2) build libupnpp-0.20.2 with build-recipe.
2.1) build upmpdcli-1.5.8 with build-recipe.
3) build libupnpp-bindings-0.20.1 with build-recipe.
4) added <upnp_albumart.py> from github - moode-develop to /var/www/command
     https://github.com/moode-player/moode
5) modified <playerlib.php>
    for script-usage as told at:
    https://github.com/moode-player/moode/co...aa2b47c8dd
thanks Tim & Kent.
What is your working config in "Edit UPnP config" please?

UPnP A/V services    = yes or no ?
OpenHome services  = yes or no ?
Reply
#60
(02-07-2021, 03:42 PM)Mark Dirac Wrote:
(01-20-2021, 12:36 AM)zOr7gA8 Wrote: it  works!!!!! woooohoooo! (pic attached)
cover is there with usage of bubble_upnp without restarting upnp-renderer ;-)))

actual test-system is:

1) moode 7.0.1 image - with following additions:
2) build libupnpp-0.20.2 with build-recipe.
2.1) build upmpdcli-1.5.8 with build-recipe.
3) build libupnpp-bindings-0.20.1 with build-recipe.
4) added <upnp_albumart.py> from github - moode-develop to /var/www/command
     https://github.com/moode-player/moode
5) modified <playerlib.php>
    for script-usage as told at:
    https://github.com/moode-player/moode/co...aa2b47c8dd
thanks Tim & Kent.
What is your working config in "Edit UPnP config" please?

UPnP A/V services    = yes or no ?
OpenHome services  = yes or no ?

AV=no
OpenHome=yes

with this config I can import tracks in moode playlist via bubble and control playlist via moode-UI.
otherwise you have only one track in moode playlist which represents the connection e.g. upnp-streaming and control playlist via control point.
Reply


Forum Jump: