Thank you for your donation!


Connect to other moOde players
#1
Photo 
Can someone explain "Connect to other moOde players"? Is it for syncing multiple players? When I have a couple players running and access the >>Players function this menu is displayed:

   

Clicking on either of these links to http://198.105.254.23/ which is not the address of either player. Thanks in advance. 

energyi
Reply
#2
Its for switching to other players UI. It uses multicast DNS to discover the other players and then a certain Linux command to determine the players IP address.

Try running the commands below and then post the output

pi@rp3:~ $ avahi-browse -a -t | awk '/IPv4/ && /moOde audio player:/ {print $7}' | sort
moode
rp1
rp2
rp3
rp4
rp5
pi@rp3:~ $ getent hosts rp1
192.168.1.170   rp1
pi@rp3:~ $


-Tim
Reply
#3
(04-10-2018, 03:12 PM)Tim Curtis Wrote: Try running the commands below and then post the output

pi@rp3:~ $ avahi-browse -a -t | awk '/IPv4/ && /moOde audio player:/ {print $7}' | sort
moode
rp1
rp2
rp3
rp4
rp5
pi@rp3:~ $ getent hosts rp1
192.168.1.170   rp1
pi@rp3:~ $


-Tim

moode
moode-3

<and>

198.105.254.23  rp1getent.Home
198.105.244.23  rp1getent.Home
198.105.254.23  hosts.Home
198.105.244.23  hosts.Home
198.105.254.23  rp1.Home
198.105.244.23  rp1.Home


energyi
Reply
#4
(04-10-2018, 05:23 PM)energyi Wrote:
(04-10-2018, 03:12 PM)Tim Curtis Wrote: Try running the commands below and then post the output

pi@rp3:~ $ avahi-browse -a -t | awk '/IPv4/ && /moOde audio player:/ {print $7}' | sort
moode
rp1
rp2
rp3
rp4
rp5
pi@rp3:~ $ getent hosts rp1
192.168.1.170   rp1
pi@rp3:~ $


-Tim

moode
moode-3

<and>

198.105.254.23  rp1getent.Home
198.105.244.23  rp1getent.Home
198.105.254.23  hosts.Home
198.105.244.23  hosts.Home
198.105.254.23  rp1.Home
198.105.244.23  rp1.Home


energyi

@energyi

So what are the actual IP addresses for your moOde players and on what host did you execute these CLI (command-line interface) commands?

Your output, both in the image you posted earlier and here, looks a bit wonky. The image says the moOde player you were on detected two players, both named moode-3; the first CLI output you give says there are two players, named moode and moode-3; the second CLI output you show has doubled entries for each host.domain name listed but it gives the appearance that getent wasn't asked about hostnames moode or moode-3.

At the moment, I have three moOde r41 players attached to my LAN; their hostnames are moode, moode-41h, and moode-up. 

From the UI of moode-41h, I get moode and moode-up displayed in the Players popup.

From the command line
Code:
pi@moode-41h:~ $ avahi-browse -a -t | awk '/IPv4/ && /moOde audio player:/ {print $7}' | sort
moode
moode-41h
moode-up
pi@moode-41h:~ $ getent hosts moode moode-41h moode-up
192.168.1.182   moode.fios-router.home
127.0.1.1       moode-41h  <--- 127.0.1.1 is a local address since I'm on this host
192.168.1.184   moode-up.fios-router.home

As you see, there is no doubling of entries here.

Regards,
Kent
Reply
#5
(04-10-2018, 05:23 PM)energyi Wrote:
(04-10-2018, 03:12 PM)Tim Curtis Wrote: Try running the commands below and then post the output

pi@rp3:~ $ avahi-browse -a -t | awk '/IPv4/ && /moOde audio player:/ {print $7}' | sort
moode
rp1
rp2
rp3
rp4
rp5
pi@rp3:~ $ getent hosts rp1
192.168.1.170   rp1
pi@rp3:~ $


-Tim

moode
moode-3

<and>

198.105.254.23  rp1getent.Home
198.105.244.23  rp1getent.Home
198.105.254.23  hosts.Home
198.105.244.23  hosts.Home
198.105.254.23  rp1.Home
198.105.244.23  rp1.Home


energyi

Hi,

It found your 2 moOde hosts. :-) Next, run commands below and post back. Thx.

getent hosts moode
getent hosts moode-3

-Tim
Reply
#6
getent hosts moode
getent hosts moode-3

-Tim


127.0.1.1       moode
<and>
198.105.254.23  moode-3.Home
198.105.244.23  moode-3.Home

Address on first is 198.168.0.13

Don't sweat this, not critical, just curious. 

energyi
Reply
#7
I have two instances of moOde running on my network. 

When both were on 4.0 when I clicked the Players option the pop-up show both moOde players (and osmc). Selecting the second player however gave no response. The only response I got was while using certain browsers (Firefox on iOS, various Desktop browsers) selecting the local player directed to an IP address (not either players' address though) and timed out.

Now both players are running 4.1 but nothing appears in the Players pop-up.
Running the code below gives no results.

Code:
avahi-browse -a -t | awk '/IPv4/ && /moOde audio player:/ {print $7}' | sort

When I run 
Code:
avahi-browse -a -t
I see
Code:
+  wlan0 IPv6 Samsung ML-1660 Series @ PiServer             _ipps._tcp           local
+  wlan0 IPv4 Samsung ML-1660 Series @ PiServer             _ipps._tcp           local
+  wlan0 IPv6 Samsung ML-1660 Series @ PiServer             Internet Printer     local
+  wlan0 IPv4 Samsung ML-1660 Series @ PiServer             Internet Printer     local
+  wlan0 IPv6 Samsung ML-1660 Series @ PiServer             UNIX Printer         local
+  wlan0 IPv4 Samsung ML-1660 Series @ PiServer             UNIX Printer         local
+  wlan0 IPv6 121D4DAE8014@Boode Airplay                    AirTunes Remote Audio local
+  wlan0 IPv6 4EA8E21A3B78@Moode Airplay                    AirTunes Remote Audio local
+  wlan0 IPv4 B827EBD53496@osmc                             AirTunes Remote Audio local
+  wlan0 IPv4 121D4DAE8014@Boode Airplay                    AirTunes Remote Audio local
+  wlan0 IPv4 4EA8E21A3B78@Moode Airplay                    AirTunes Remote Audio local
+  wlan0 IPv6 boode                                         Remote Disk Management local
+  wlan0 IPv6 moode                                         Remote Disk Management local
+  wlan0 IPv4 osmc                                          Remote Disk Management local
+  wlan0 IPv4 boode                                         Remote Disk Management local
+  wlan0 IPv4 moode                                         Remote Disk Management local
+  wlan0 IPv6 xxxxx's iPad                                  _companion-link._tcp local
+  wlan0 IPv4 xxxxx's iPad                                  _companion-link._tcp local
+  wlan0 IPv4 osmc                                          SSH Remote Terminal  local
+  wlan0 IPv4 osmc                                          SFTP File Transfer   local
+  wlan0 IPv4 osmc                                          Web Site             local
+  wlan0 IPv4 osmc                                          _xbmc-jsonrpc-h._tcp local
+  wlan0 IPv4 osmc                                          _xbmc-jsonrpc._tcp   local
+  wlan0 IPv4 osmc                                          _xbmc-events._udp    local
pi@moode:~ $
Reply
#8
Hi,

This is due to a bug in the in-place update package (missing config file).

Try adding the file: /etc/avahi/services/moode.service

1. sudo nano /etc/avahi/services/moode.service
2. paste the code below into the empty file
3. Ctrl-o <return> Ctrl-x to save the file
4. Reboot

<?xml version="1.0" standalone='no'?><!--*-nxml-*-->
<!DOCTYPE service-group SYSTEM "avahi-service.dtd">

<service-group>
<name replace-wildcards="yes">moOde audio player: %h</name>
<service>
<type>_http._tcp</type>
<port>80</port>
</service>
</service-group>

-Tim
Reply
#9
(04-11-2018, 12:25 PM)Tim Curtis Wrote: 2. paste the code below into the empty file

File not empty:
GNU nano 2.7.4       File: /etc/avahi/services/moode.service

<?xml version="1.0" standalone='no'?><!--*-nxml-*-->
<!DOCTYPE service-group SYSTEM "avahi-service.dtd">

<service-group>
        <name replace-wildcards="yes">moOde audio player: %h</name>
        <service>
                <type>_http._tcp</type>
                <port>80</port>
        </service>
</service-group>


energyi
Reply
#10
If the file exists the it should look exactly like below.

Code:
pi@rp3:~ $ cat /etc/avahi/services/moode.service
<?xml version="1.0" standalone='no'?><!--*-nxml-*-->
<!DOCTYPE service-group SYSTEM "avahi-service.dtd">

<service-group>
       <name replace-wildcards="yes">moOde audio player: %h</name>
       <service>
               <type>_http._tcp</type>
               <port>80</port>
       </service>
</service-group>
Reply


Forum Jump: