Thank you for your donation!


Samba share issue (NAS on DD-WRT)
#1
Hi

I'm having a problem mounting the share which has my FLAC library.

Currently, my NAS is a USB drive shared from my DD-WRT router.
The share is a public share with no username or password 

\\DD-WRT\Media\New FLAC

This root share (DD-WRT\Media) is visible and accepts connections from many device in the house. Devices include Windows, Squeezebox (windows LMS server to be fair), nvidia shield, roku, firetv etc.......

Within the NAS sourc>Create NAS source
Scan results in the share being visible 

Type - SMB (Samba)
Server - DD-WRT/Media
User ID
Password
Name - FLAC

Various combinations of mount flags
vers=1.0,ro,dir_mode=0777,file_mode=0777
vers=2.0,ro,dir_mode=0777,file_mode=0777
vers=3.0,ro,dir_mode=0777,file_mode=0777

All result in the error
20180927 084209 wrk_sourcemount(): Mount error: (username specified with no parameter)

I've tried appending the mount flags with which it doesnt like as it errors and lists the switch options
vers=X.0,ro,dir_mode=0777,file_mode=0777,user=,password=

20180927 084552 wrk_sourcemount(): Mount error: (
Usage:
mount [-lhV]
mount -a [options]
mount [options] [--source]
| [--target]

mount [options]  
mount   []

Mount a filesystem.

Options:
-a, --all               mount all filesystems mentioned in fstab
-c, --no-canonicalize   don't canonicalize paths
-f, --fake              dry run; skip the mount(2) syscall
-F, --fork              fork off for each device (use with -a)
-T, --fstab       alternative file to /etc/fstab
................................................................and so on



I've tried to adjust the share on DD-WRT by adding a second share which has a username and password then add the user and password to the Moode config
(share is picked up by scan)

Type - SMB (Samba)
Server - DD-WRT/FLAC
User ID - pi
Password - moodeaudio
Name - FLAC

Various combinations of mount flags
vers=1.0,ro,dir_mode=0777,file_mode=0777
vers=2.0,ro,dir_mode=0777,file_mode=0777
vers=3.0,ro,dir_mode=0777,file_mode=0777

This gives me the error 

20180927 085511 wrk_sourcemount(): Mount error: (mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))


So far as I can tell, the mount commands generated by the app specifically need a username and password.

My preference would be to mount this public share (public within my own private network) without any credentials.
Clearly I don't want to make changes that effect all of the other devices at home that access this NAS share on my router.

There seems to be quite a lot on various forums regarding problems with cifs mounts and this non descript error however I've not seen any definitive solution.

I realise this may be a configuration issue on either device but the fact that the share is visible everywhere else would suggest that in this case its a problem at the client end.

It cant be that difficult to mount a network share in linux can it????? lol

TIA

Ian 
Reply
#2
Hi Ian,

Try userid=Guest and a blank password. Leave the mount flags at the default setting i.e., vers=1.0 ...
Reply
#3
Wow!!!

I could have sworn that I tried Guest and the default flags without success during as I searched for answers last night!!!

I can conform its now working as per your suggestion above.....

Thanks for your quick reply to both of my recent posts!
Reply
#4
Maybe I'll add some additional (i) info text to the screen :-)
Reply
#5
Definitely cant hurt Smile
Reply


Forum Jump: