Thank you for your donation!


Problem: moode 4.3 Spotify Connect issue
#21
Reloading Spotify and Restarting the Phone does not working sadly, it also doesn't appear on Spotify Windows.

Yes I do have a Spotify Premium account.

Can i check via ssh if the renderer works properly?
Reply
#22
Try

pgrep -l librespot to verify thats it running.

Also

/var/www/command/sysinfo.sh

Then post the contents of the Spotify section. It should look like below.

Code:
      S P O T I F Y    S E T T I N G S  

       Friendly name           = RP3 Spotify
       ALSA device             = default:CARD=Katana
       Resume MPD              = Yes
       Bit rate                = 320
       Initial volume          = 0
       Volume curve            = Logarithmic
       Volume normalization    = No
       Normalization pregain   = 0
Reply
#23
Well, that's just bragging you are beta-testing a Katana! Tongue
Reply
#24
lol, Katana gets the tech blood flowing :-)

Looks like version 1.2 is almost ready for release!
Reply
#25
(10-05-2018, 02:28 PM)Tim Curtis Wrote: Try

pgrep -l librespot to verify thats it running.

Also

/var/www/command/sysinfo.sh

Then post the contents of the Spotify section. It should look like below.

Code:
      S P O T I F Y    S E T T I N G S  

       Friendly name           = RP3 Spotify
       ALSA device             = default:CARD=Katana
       Resume MPD              = Yes
       Bit rate                = 320
       Initial volume          = 0
       Volume curve            = Logarithmic
       Volume normalization    = No
       Normalization pregain   = 0


pgrep -l librespot returns nothing and /var/www/command/sysinfo.sh returns:


Code:
   S P O T I F Y    S E T T I N G S

        Friendly name           = Kueche
        ALSA device             = default:CARD=sndrpijustboomd
        Resume MPD              = No
        Bit rate                = 160
        Initial volume          = 50
        Volume curve            = Logarithmic
        Volume normalization    = No
        Normalization pregain   = 0


in the sysinfo.sh further down i can see:


Code:
    20181005 163710 worker: Spotify receiver started


After Restarting the spotify Renderer from the gui:


Code:
    20181005 165021 worker: Job spotifysvc
    20181005 165033 worker: Job spotifysvc
Reply
#26
(10-05-2018, 01:18 PM)thomas4130 Wrote: Reloading Spotify and Restarting the Phone does not working sadly, it also doesn't appear on Spotify Windows.

Yes I do have a Spotify Premium account.

Can i check via ssh if the renderer works properly?

And all three devices (phone, Windows host, moOde) are on the same network?

Can your Spotify app on your phone "see" (e.g., list it under Devices Available) the Spotify app on your Windows host and v.v.? 

I can bounce back and forth between Spotify apps on my Android devices and my iPad, using either one of them, or my Amazon Echo, or my moOde players as the output device.

Regards,
Kent
Reply
#27
Yes all devices are on the same network. I'm using spotify conenct without problems on the xbox and fire stick.
I can also see all hosts on my phone (tablet/Windows host etc)
Reply
#28
Same here.
Reply
#29
Suddenly this evening for the first time I've had a lot of trouble with Spotify Connect. I finally got it playing but it keeps losing the connection. I guess it must be a network issue, unless it's something going on with Spotify itself.
Reply
#30
(10-05-2018, 02:51 PM)thomas4130 Wrote: pgrep -l librespot returns nothing

This indicates that it is not running and most likely has crashed for some reason.

If its running you will see something like below
Code:
pi@rp3:~ $ pgrep -l librespot
26240 librespot

-Tim
Reply


Forum Jump: