Thank you for your donation!


Album Cover View thumbnail is first (alpha sorted) image in album directory
#1
The thumbnail shown in Album View panel is the first (00*.jpg in the cases I've uncovered) listed image file even when an appropriately named cover image (folder.jpg, cover.jpg etc) image exists in the directory.
The result is a different image in the Album View Panel to the one that shows as the album cover when you select the album in either album view panel or library panel.

I have the preference set to prefer image files in directory to embedded image in audio file.
Reply
#2
Post a file listing for one of the directories where this issue arises and I'll have a look.
Reply
#3
(10-01-2018, 02:49 PM)Tim Curtis Wrote: Post a file listing for one of the directories where this issue arises and I'll have a look.

Code:
01. Father Cannot Yell.mp3
02. Mary, Mary So Contrary.mp3
03. Outside My Door.mp3
04. Yoo Doo Right.mp3
Back.jpg
CD.jpg
folder.jpg
Front.jpg

Back.jpg is displayed in Album Cover panel but folder.jpg (or Front.jpg they are actually the same file) is the album cover when playing or in library.

Similarly other directories with (only) back.jpg and folder.jpg display folder.jpg as album cover but back.jpg as Album Cover Panel thumbnail.

Then this kind of thing too


Code:
01*.mp3
02*.mp3
...
10*.mp3
cover.jpg
March Of Noise Blog.jpg


And Album Cover panel displays March Of Noise Blog.jpg but cover.jpg is the album cover recognised otherwise.

Also a directory containing a file 00-ARTISTNAME-ALBUMNAME-YEAR.jpg and folder.jpg displays folder.jpg as album cover but the other file is the thumbnail in album cover panel.
 
And a different directory which has 00-ARTISTNAME-ALBUMNAME-YEAR.jpg as the only image, no embedded image, displays the jpg as the album cover but generates no thumb for ALbum Cover View panel.

Also directory with folder.jpg and flac files with no embedded image, album cover is picked up but no thumbnail generated.
Reply
#4
First thing to check is moode log for the start and end messages from thmcache: and for any errors from thmcache:

cat /var/log/moode.log

20181001 125057 thmcache: Start
20181001 125208 thmcache: Done: 341 album dirs processed

If the start and end messages are present and there are no errors then zip up one of the albums with the image files and email me a download link. Also I'll need the entire directory path to the dir containing the files so i can recreate it on my end.

-Tim
Reply
#5
(10-01-2018, 04:53 PM)Tim Curtis Wrote: First thing to check is moode log for the start and end messages from thmcache: and for any errors from thmcache:

cat /var/log/moode.log

20181001 125057 thmcache: Start
20181001 125208 thmcache: Done: 341 album dirs processed

If the start and end messages are present and there are no errors then zip up one of the albums with the image files and email me a download link. Also I'll need the entire directory path to the dir containing the files so i can recreate it on my end.

-Tim

Ok. I am rebuilding my library and then thumbnails to further test. If no progress or further clues are found I will send you some files. Thanks.
Reply


Forum Jump: