Thank you for your donation!


Update 4.2 to 4.3 Questions
#11
Thats just the top part of System info. You have to highlight and drag the mouse down until all the output is highlighted then copy/paste
Reply
#12
(10-07-2018, 10:27 AM)aBrianH Wrote: Falpi
Have you tried different browsers e.g. Chrome, Safari or Explorer.

I use Chrome and Explorer only.
Reply
#13
Here you go, Tim:

Code:
ROOT size    = 2.9G
ROOT used = 72%
ROOT avail    = 783M
FS expand    = not expanded
MEM free = 403 MB
MEM used = 72 MB
Temperature = 51.5°C

CPU GOV    = performance
MPD SCHDPOL    = TS
P3-WIFI    = On
P3-BT    = On
HDMI    = On
ETH0 CHECK    = On
MAX USB CUR    = Off
UAC2 FIX    = Off
SSH server    = Off

LED0    = on
LED1    = on

C O R E    S E R V E R S  

PHP-FPM    = 7.0.30
NGINX    = 1.10.3
SQLite    = 3.16.2

C P U    L O A D  

CPU    %usr    %sys    %idle
all    0.13    0.00    99.75
0    0.51    0.00    98.98
1    0.00    0.00    100.00
2    0.00    0.00    100.00
3    0.00    0.00    100.00

P R O C E S S    L O A D  

PRI RTPRIO COMMAND         %MEM PSR %CPU
19      - sysinfo.sh       0.2   3  2.3
19      - worker.php       1.2   0  0.3
19      - php-fpm7.0       1.3   1  0.2
19      - php-fpm7.0       1.1   0  0.2
19      - kworker/u8:3     0.0   1  0.1
19      - systemd          0.6   3  0.0
19      - kthreadd         0.0   3  0.0
39      - kworker/0:0H     0.0   0  0.0
39      - mm_percpu_wq     0.0   0  0.0

C L O C K    F R E Q U E N C I E S  

   arm   = 600 MHz             pwm   = 0 MHz
   core  = 250 MHz             emmc  = 200 MHz
   h264  = 250 MHz             pixel = 25 MHz
   isp   = 250 MHz             vec   = 126 MHz
   v3d   = 250 MHz             hdmi  = 163 MHz
   uart  = 48 MHz             dpi   = 0 MHz

SD card    = 50 MHz

S Y S T E M    V O L T A G E S  

core    = 1.2000V
sdram controller    = 1.2000V
sdram I/O    = 1.2000V
sdram chip    = 1.2250V

cat: /proc/asound/card0/pcm0p/sub0/hw_params: No such file or directory
cat: /proc/asound/card0/pcm0p/sub0/hw_params: No such file or directory
U I  C U S T O M I Z A T I O N S  

Theme    = Standard
Accent color    = Emerald
Alpha blend    = 1.0
Adaptive background    = No
Background image    = No
Playback history    = No
Extra metadata    = Yes
Artist list order    = Artist
Cover search pri    = Embedded cover
Hi-res covers    = No
Pixel ratio    = 2

A U D I O    P A R A M E T E R S  

Audio device    = HiFiBerry DAC+
Interface    = I2S
Hdwr volume    = Controller detected
Mixer name    = Digital
Output stream    = Closed
ALSA version    = 1.1.3-5+rpi3
SoX version    = 0.1.2-2

Volume knob    = 13
Volume mute    = Unmuted

Bluetooth controller    = Off
Airplay receiver    = Off
Spotify receiver    = 0
Squeezelite    = Off
UPnP client    = Off
DLNA server    = Off

Rotary encoder    = Off
Encoder params    = 100 2 3 4 5
Crossfeed    = Off
Parametric EQ    = Off
Graphic EQ    = Off
Auto-shuffle    = Off
Autoplay    = Off
MPD crossfade    = Off

M P D    S E T T I N G S  

Version    = 0.20.20
Volume control    = software
ALSA device    = hw:0
SoX resampling    = disabled
SoX quality    = very high
SoX multithreading    = off
Audio buffer (kb)    = 4096
Buffer before play    = 10%
Output buffer size (kb)    = 81920
Volume normalization    = No
DSD over PCM (DoP)    = no
Replay gain    = off

B L U E T O O T H    S E T T I N G S  

Bluetooth ver    = 5.49
Bluealsa ver    = Turn BT on for version info
Speaker sharing    = No
Resume MPD    = No

A I R P L A Y    S E T T I N G S  

Version    = 3.2.1
Friendly name    = Moode Airplay
ALSA device    = hw:0
Volume mixer    = auto
Resume MPD    = No
Output bit depth    = S16
Output sample rate    = 44100
Session interruption    = no
Session timeout (ms)    = 120
Audio buffer (secs)    = 0.0

S P O T I F Y    S E T T I N G S  

Friendly name    = Moode Spotify
ALSA device    =
Resume MPD    = No
Bit rate    = 160
Initial volume    = 0
Volume curve    = Logarithmic
Volume normalization    = No
Normalization pregain    = 0

S Q U E E Z E L I T E    S E T T I N G S  

Version    = 1.8.7-1052 "DSD/SRC enabled"
Friendly name    = Moode
ALSA device    = hw:0
ALSA params    = 80:4::1
Output buffers    = 40000:100000
Task priority    = 45
Codec list    = flac,pcm,mp3,ogg,aac,alac,dsd
Resume MPD    = No
Other options    = -W -D 500 -R E -S /var/loca

M O O D E    L O G  

  20181007 115740 worker: - Start
  20181007 115740 worker: Successfully daemonized
  20181007 115740 worker: Session loaded
  20181007 115740 worker: Debug logging (off)
  20181007 115740 worker: - Platform
  20181007 115742 worker: Host (moode)
  20181007 115742 worker: Hdwr (Pi-3B 1GB v1.2)
  20181007 115742 worker: Arch (armv7l)
  20181007 115742 worker: Rasp (9.4)
  20181007 115742 worker: Kver (4.14.72-v7+)
  20181007 115742 worker: Ktyp (Standard)
  20181007 115742 worker: Gov  (performance)
  20181007 115742 worker: Rel  (Moode 4.3 2018-09-27)
  20181007 115742 worker: Upd  (None)
  20181007 115742 worker: MPD  (0.20.20)
  20181007 115742 worker: USB boot not enabled yet
  20181007 115754 worker: File system not expanded yet
  20181007 115754 worker: HDMI port on
  20181007 115754 worker: File check ok
  20181007 115754 worker: - Network
  20181007 115754 worker: eth0 exists
  20181007 115754 worker: eth0 wait 0 for IP address
  20181007 115757 worker: eth0 wait 1 for IP address
  20181007 115809 worker: eth0 wait 2 for IP address
  20181007 115812 worker: eth0 wait 3 for IP address
  20181007 115815 worker: eth0 wait 4 for IP address
  20181007 115818 worker: eth0 wait 5 for IP address
  20181007 115821 worker: eth0 wait 6 for IP address
  20181007 115824 worker: eth0 wait 7 for IP address
  20181007 115827 worker: eth0 wait 8 for IP address
  20181007 115830 worker: eth0 wait 9 for IP address
  20181007 115833 worker: eth0 address not assigned
  20181007 115833 worker: wlan0 exists
  20181007 115833 worker: wifi country (US)
  20181007 115833 worker: wlan0 trying SSID (poochnet)
  20181007 115833 worker: wlan0 (192.168.1.11)
  20181007 115833 worker: - Audio
  20181007 115834 worker: ALSA outputs unmuted
  20181007 115834 worker: ALSA card number (0)
  20181007 115834 worker: Audio out (I2S audio device)
  20181007 115834 worker: Audio dev (HiFiBerry DAC+)
  20181007 115834 worker: ALSA mixer name (Digital)
  20181007 115834 worker: MPD volume control (software)
  20181007 115834 worker: Hdwr volume controller exists
  20181007 115834 worker: Chip options (Burr Brown PCM5122)
  20181007 115834 worker: - Services
  20181007 115834 worker: Reset renderer active
  20181007 115836 worker: MPD started
  20181007 115836 worker: MPD scheduler policy (time-share)
  20181007 115836 worker: Configure MPD outputs
  20181007 115837 worker: MPD output 1 ALSA default (on)
  20181007 115837 worker: MPD output 2 ALSA crossfeed (off)
  20181007 115837 worker: MPD output 3 ALSA parametric eq (off)
  20181007 115837 worker: MPD output 4 ALSA graphic eq (off)
  20181007 115837 worker: MPD output 5 ALSA bluetooth (off)
  20181007 115837 worker: MPD crossfade (off)
  20181007 115837 worker: - Music sources
  20181007 115837 worker: USB source (TUNELETS)
  20181007 115837 worker: NAS sources (none configured)
  20181007 115837 worker: - Miscellaneous
  20181007 115837 worker: Volume level (13) restored
  20181007 115837 worker: Maintenance interval (21600)
  20181007 115837 worker: Screen saver activation (Never)
  20181007 115837 worker: Watchdog started
  20181007 115837 worker: Ready
Reply
#14
The line below suggests that Linux has not registered the audio device.

Code:
cat: /proc/asound/card0/pcm0p/sub0/hw_params: No such file or directory

Maybe try re-seating it or spraying a bit of contact cleaner on the 40-pin header, siomething like that.

-Tim
Reply
#15
Code:
Audio device = HiFiBerry DAC+

Is this the correct driver for your device? Collybia recommend using the Mamboberry driver:

"From the settings page at Archphile OR MoOde player, you should simply choose from the list of DAC’s, the Mamboberry HiFi DAC+."
Reply
#16
(10-07-2018, 09:17 PM)Tim Curtis Wrote: The line below suggests that Linux has not registered the audio device.

Code:
cat: /proc/asound/card0/pcm0p/sub0/hw_params: No such file or directory

Maybe try re-seating it or spraying a bit of contact cleaner on the 40-pin header, siomething like that.

-Tim
Reply
#17
Took the thing all apart and sprayed some contact cleaner in the header sockets, wiggled it in and out a few times, reassembled.

Started up, re-selected the dac, rebooted. 

No love. Still getting the "No such file or directory" message in the system info.

Funny thing is, it worked perfectly for more than a year before with 3x and yesterday with 4.2.

I'll double-check the power connection to the board, but other than that I'm completely stumped.
Reply
#18
Thats very odd.

After setting the I2S driver to Mamboberry HIFI DAC and then rebooting, did u remember to open MPD config and APPLY the settings?

Basically if /boot/config.txt has the line dtoverlay=hifiberry-dac which is the correct I2S driver for that Mamboberry board then Linux should register it and assign it to card 0 (hw:0).

A successful device registration would show in the output of the dmesg command.

Feel free to post the output of dmesg and I'll have a look.

-Tim
Reply
#19
OK, wow, so not obvious. So did this just now, with no result.

You need to know I'm a part of your user base who is just a guy who wants a music player and has zero experience with Linux or anything command-line oriented. So all of this is very opaque to me.

I'm guessing the the "output of dmesg" involves ssh-ing in and typing in that line? Please confirm and add anything else I need to know and I'll give it a whack.
Reply
#20
moOde and Raspberry Pi is a great way to learn some Linux :-)

Yes, you would type the cmd dmesg at the SSH prompt.

Open moOde System config screen and scroll down to Local Services. Turn on the SSH term server and then OPEN it. The userid is Pi and password is moodeaudio.
Reply


Forum Jump: