Thank you for your donation!


Instruction Guide Properly set audio (alsa) moode params for Iqaudio Dac-Pro
#1
Hi everyone,

I have a "simple" question. I am switching from another (PimusicBox) OS music oriented to Moode. I have some trouble to find the
best settings for my config using moode.
Hardware : raspberry pi 3 B+  with Iqaudio Pi DAC-PRO

In the Iqaudio manual, they precise that we should set Volume around 20% (alsa).
If I do that, the volume is really really low.
If I try to set 100% it's loud (maybe too much), I haven't test it extensively, but it seems that I ear a lot of distortion and I am afraid to damage the Dac-Pro.

I have the feelings that something is outdated on the Iqaudio's documentation. And I am a bit lost, I am more familiar with the direct interaction in config file in command line.
I don't know what exactly moode is doing when I change params (is it writing something somewhere in the general alsa config? etc...)

Finally, what matter is the sound quality without destroying the pi DAC-PRO nor the amplifier behind.

Could someone tell me the appropriates settings for this setup. And other specifics parameters relative to the audio parts.

Thank you.
Reply
#2
How do you operate your volume? By software in within moode GUI or on your amplifier?
In the first case you just adjust appropriate volume to your listening level each time. In 2nd scenario you disable volume control in moode settings (none option) an use volume control on your amplifier
Reply
#3
Actually, the 20% story is coming directly from iQaudio manual V.20 :
"connect from web browser to moode.local
select configure from the pull down menu, then system.
Within the Audio section select the IQaudio device you have (such as Pi-DAC+) and press SET
Within the same selection make sure you set the volume to around 20% (not 100%) and press SET
Select reboot "

I am currently using moode only.
And I only use the settings available through the (G)UI. I followed exactly the procedure described in iQaudio manual.
This evening I will do some test. I think one solution could be to set Alsa to 100% in the UI, but use a setting of -6 dB for the analog volume. In my opinion this should result in a lower output level and avoid the problem of "too loud and distorted sound" that I am experimenting.

Another approach could be to find a solution to limit the level at 50 or 75 % in alsa.
This way, I hope have a final output of the same order as my CD player typically.

The point is to find a way to definitely be certain that I am using the DAC card as it should be (for the best sound quality perf) and avoid over loud setting even when moode is used as renderer from Android bubbleUpnp for example.

The full config is:
moode running on raspberry Pi 3+ with iQaudio DAC-pro connected to NAIM integrated amplifier.
Usage : moode controlled from web browser (mostly for web-radio listening), or from bubbleUpnP or from idevice (shairport-sync)
Reply
#4
(10-18-2018, 08:29 AM)motkawa Wrote: Hi everyone,

I have a "simple" question. I am switching from another (PimusicBox) OS music oriented to Moode. I have some trouble to find the
best settings for my config using moode.
Hardware : raspberry pi 3 B+  with Iqaudio Pi DAC-PRO

In the Iqaudio manual, they precise that we should set Volume around 20% (alsa).
If I do that, the volume is really really low.
If I try to set 100% it's loud (maybe too much), I haven't test it extensively, but it seems that I ear a lot of distortion and I am afraid to damage the Dac-Pro.

I have the feelings that something is outdated on the Iqaudio's documentation. And I am a bit lost, I am more familiar with the direct interaction in config file in command line.
I don't know what exactly moode is doing when I change params (is it writing something somewhere in the general alsa config? etc...)

Finally, what matter is the sound quality without destroying the pi DAC-PRO nor the amplifier behind.

Could someone tell me the appropriates settings for this setup. And other specifics parameters relative to the audio parts.

Thank you.

There are either going to be 2 or 3 volume control options in MPD config.  If your audio device has an on-chip volume controller then the 3rd option, "Hardware" volume option will appear. Hardware volume is ALSA volume. moOde automatically configures ALSA volume if it exists. This setting should never be manually changed.

The example below showing MPD volume control options assumes the audio device has a Hardware volume controller.

1. Disabled (0dB output)
Sets ALSA volume to 100%
MPD always outputs 100% volume.
The resulting overall volume output is thus 100% (0dB)
WARNING: your amp needs to have a physical volume control

2. Software
Sets ALSA volume to 100%
MPD volume varies logarithmically between 0 and 100%
At MPD 100% the overall volume level will be 100% (0dB)

3. Hardware
MPD varies ALSA volume logarithmically from 0-100%
At MPD 100%, ALSA will be 100% (0dB)

For the IQAudIO DAC PRO, just set MPD volume to Hardware and then APPLY.

-Tim
Reply
#5
Thank you for your help,

Since I am using my own amp with the volume controller, I don't need the "on fly" wireless controller integrated to MPD. Finally what I did is :
using 1. (disabled) in MPD and modify Alsa from 100 to 85 (did that in "audio" menu) because at 100 it's definitely not good. The sound is like it's saturated very similar of what you ear when you push far too loud your speakers.
To test that I use one track that I have in original CD and in flac. I use the CD player as ref. And try to find the setting which offer something clean on the DAC PRO.
I am more or less satisfy.
Reply
#6
Thats very odd that ALSA volume would have to be attenuated because that would not be normal for that DAC.

If you login via SSH and type the command below it should show 0dB when the volume is raised to 100%.

alsamixer

You might want to adjust the Chip options and lower the Analog gain and Analog gain boost, leaving ALSA volume at 100%.

Menu, Configure, Audio
Chip/device options: EDIT SETTING
Reply
#7
Hi Tim,

thank ou for your reply, I completely agree with you, and I don't really have any explanation. I try a lower Analog gain boost and analog gain, it's better, but still not perfect and it's not what recommend IQaudio.
I try to do some test sound directly with mplayer using only raspbian properly parameterized with alsa at 0 dB and the gain set as defined by IQaudio in the manual, and that works.
Finnaly driving by curiosity I try Volumio, and everything is fine.

I haven't have time to check from where it comes, but too me it could be due to a different version of MPD or ALSA (?).
It's very strange.
When I check with alsamixer it's the same settings but obviously that sound different. (not different in audiophile terms ;-) ) Different such as one is OK and the other one make your ears bleeding due to the distortion.
Reply
#8
Very odd. I ran a  quick test with an IQaudio DACZero which uses the same I2S driver as the DAC PRO and no distortion whatsoever at 0dB output into my Amplified system w/phy volume control. Chip options are at the IQaudIO defaults.

The configuration is bit-perfect meaning that all DSP is off including:

- Graphic EQ
- Parametric EQ
- Crossfeed
- MPD Crossfade
- MPD Replay Gain
- MPD SoX resampling
- MPD Volume normalization

-Tim
Reply
#9
(10-22-2018, 08:43 AM)motkawa Wrote: Hi Tim,

thank ou for your reply, I completely agree with you, and I don't really have any explanation. I try a lower Analog gain boost and analog gain, it's better, but still not perfect and it's not what recommend IQaudio.
I try to do some test sound directly with mplayer using only raspbian properly parameterized with alsa at 0 dB and the gain set as defined by IQaudio in the manual, and that works.
Finnaly driving by curiosity I try Volumio, and everything is fine.

I haven't have time to check from where it comes, but too me it could be due to a different version of MPD or ALSA (?).
It's very strange.
When I check with alsamixer it's the same settings but obviously that sound different. (not different in audiophile terms ;-) ) Different such as one is OK and the other one make your ears bleeding due to the distortion.

@motkawa 

I read the current IQaudIO User Guide v27 and its instructions for moOde setup. 

The pdf file-date reported on their website is 2017-09-10. This predates the release of moOde r4.0 based on Raspbian Stretch. Have you asked IQaudIO for an explanation of the instruction "Within the same selection make sure you set the volume to around 20% (not 100%) and press SET"? What's their advice for moOde r4.x?

Regards,
Kent

PS - have you compared the outputs for the two systems from dmesg, lsmod, and aplay -l to see if your moOde and Volumio setups with the IQaudIO Pi-DAC Pro are exercising the same low-level kernel modules?
Reply
#10
Hi,
Yes I send an e-mail to IQaudIO to have some input about this strange (outdated) setup. I haven't received any answer at this day.
I haven't done the comparison of the low level kernel modules between volumio and moode.
Unfortunately I am running volumio now and I did all the settings (network files etc...).
If I find a microSD somewhere at home, I will do the comparison and report the result here as soon as I have time. I am curious to understand what happen.

Regards,
Reply


Forum Jump: