Thank you for your donation!

Khadas Tone Board
Hmmm... my limited linux skills hit a snag...
compiled but cannot run...


sudo make install
install -D -m 755 alsacap /usr/local/bin/alsacap
install -D -m 644 alsacap.1 /usr/local/share/man/man1/alsacap.1
$ alsacap
-bash: /usr/local/bin/alsacap: cannot execute binary file: Exec format error
The error seems to refer to an x86 binary being run on arm ???
"Mediocrity is achievable. This may explain it's popularity." 
No worries.

The procedure below worked perfectly for me

sudo unzip -q ./
sudo rm ./
cd ./alsacap-master

sudo ./bootstrap
sudo ./configure
sudp make
sudo make dist


sudo cp alsacap-1.0.tar.gz ~/
cd ~/
sudo tar xfz ./alsacap-1.0.tar.gz
cd alsacap-1.0

sudo ./configure
sudo make

I didn't run make install cos no need for the man page. The binary is ./alsacap-1.0/src/alsacap

This can be copied to /usr/local/bin and given +x permission

It was trivial to replace alsa-capabilities with alsacap in moOde. Now we get formats for USB Audio devices :-)

Thx again Bob!
That worked for me too ! Thanks for the clear instructions.. Smile
"Mediocrity is achievable. This may explain it's popularity." 
(02-07-2020, 04:55 PM)stefano_mbp Wrote: my dear old friend, it would be a better approach to assume that you made some mistakes instead of suggesting the solution of the reported problem to be postponed to third parties

Was my response immoderate, yes, and for that I apologize.

Did I make a mistake, no. The problem wasn't with alsa, it was with the utility alsa-capabilities, just as I said.

Done and dusted now that Tim has folded in alsacap.

I am faced with a choice of Pi2Design 502DAC or Khades Tone Board. What can you recommend for using together with moOde?
I am currently using the hdmi output to connect to the Denon AVR-1311 receiver.

PS. excuse me for my English.

Forum Jump: