Thank you for your donation!


Khadas Tone Board
#21
@liv_s

I noted your "New MoOde player" post. Nice.

Have you resolved the Hardware Volume issue?

Your posts have got me interested in the Khadas Tone Board. If you are willing and have the time, could you do the following couple of steps?

Step 1:

Code:
pi@moode:~ $ lsusb
Bus 001 Device 002: ID 041e:3125 Creative Technology, Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

This is just an example with my Creative W2 USB-Audio adapter plugged in. Note that it had USB VendorTongueroduct ID 041e:3215.

I expect you'll see an entry like xCore ... or XMOS ... for your KTB. Please note the USB VendorTongueroduct ID XXXX:YYYY and use it in the following step.

Step 2:

Code:
pi@moode:~ $ sudo lsusb -v -d XXXX:YYYY > ktb-lsusb.txt

The ktb-lsusb.txt file generated in this step may be long (it was 235 lines for my Creative-W2). Please send it as an attachment to your reply. Thanks.

Regards,
Kent
Reply
#22
Hi Kent

Not solved for now, and as i do not have so much experience i let as it is. I will do a check with volumio again.

What you ask for:
step 1 Bus 001 Device 004: ID 20b1:000a XMOS Ltd
step 2 attached

Thanks


Attached Files
.zip   ktb-lsusb.zip (Size: 1.92 KB / Downloads: 4)
Reply
#23
(03-30-2019, 10:53 PM)liv_s Wrote: Hi Kent

Not solved for now, and as i do not have so much experience i let as it is. I will do a check with volumio again.

What you ask for:
step 1 Bus 001 Device 004: ID 20b1:000a XMOS Ltd
step 2 attached

Thanks

Thanks for that. I'll let you know if I can spot any clues.

Regards,
Kent
Reply
#24
So I've been diagnosing the Khadas Tone Board with Moode r5.3 and shooting Tim posts as I do. We've figured out the Hardware Volume Control detection problem. It was due to a blunder in the Khadas XMOS firmware which was inconsistently encoding the USB string descriptors for the interfaces. Tim has adjusted for this behavior in the moOde r5.3.1 update.

The good news? moOde now detects the presence of the KTB's Hardware Volume Control and the MPD config panel offers all three choices for volume control: Hardware, Software, and Disabled.

The not-so good news? The Khadas hardware control function seems to work only for PCM playback. With DSD material, I have either to select Disabled or select Hardware and set moOde's volume at 100 percent. I can then play native DSD and DSD-over-PCM while controlling volume at my amplifier.

This is a Khadas issue, not a moOde issue; it affects that other FOSS RPi music player too. The DAC chip spec sheet says it can do hardware control and Tim tells me it works with his Allo Katana, which uses the same chip.

I've spent a lot of time on the Khadas forum reading all the back posts and then posting about the string descriptor problem. Candidly, I'm not holding my breath until they fix either this problem or solve the DSD hardware control problem. The XMOS controller is well documented and third parties have hacked a bit at the firmware. Perhaps one of the DIYaudio cognoscenti will solve the problems.

Regards,
Kent
Reply
#25
Since last firmware update nothing happen, as expected. I will not see soon something as guys from Khadas intend to provide a second edition of KTB.
I am not looking for a solution right now, as I want to keep hardware volume at 100%, as I did before.
And another solution is to do Sox settings as 32 bits and 384, maximum for KTB (I know is not ok for quality).

However, it seams that KTB has a higher volume at output and this will generate distorsions.
I discover this as I install between KTB and AVR (ONKYO TX609) an EQ Kenwood GE7030. And the bargraph for some songs are shown at high limits. If I set the volume in alsa at 90% (or lower) the sound level is going down and distortions fade away. But in this case I can not play DSD, which point me to the solution above (Sox).
My question is if there is an other possible setting to decrease output level and to maintain hardware volume at 100%.
I hope I was clear.
Reply
#26
Where is the distortion being generated? If the downstream equipment is being overdriven by the KTB, try inserting a passive attenuator between them. 

Regards,
Kent
Reply
#27
Hi Kent,

What I know:
- KTB to power amplifier - distorsions at 100%
- KTB to AVR (with or without EQ) - distorsions at 100%, none or inaudible at 70%
- CD player to AVR, same input - none
With the same flac source for first two, different cd's for last.
So I have to go with your solution, thanks.
Or to make settings in AVR to reduce input with lets say -5dB (Onkyo Intellivolume).
Analog part of KTB deliver higher level which has an impact downstream.
I will do further tests.

LE:
I do several tests for last 2 hours and I have to admit I was wrong.
The culpit is EQ. It induce several distortions by increasing for some eq curves the output. I do not think is normal, but this is another discussion.
So my conclusion is KTB = ok.

Kent, can you delete my last posts please, does not help the topic
Reply


Forum Jump: