Thank you for your donation!


Allowing internet access while in AP mode (on mobile)
#11
Very nice to see this discussion. Count me in as an interested party and tester if needed.
Reply
#12
Nice :-)

I'm going to try and run some tests this week.
Reply
#13
(11-12-2018, 05:12 PM)Tim Curtis Wrote: Nice :-)

I'm going to try and run some tests this week.

I just tried this out with fingers crossed on the latest build. Any luck in your tests? Smile
Reply
#14
I never ended up testing because after thinking about it for a bit the feature doesn't seem to have broad enough appeal to be baked into moOde and there are the issues that it only seems to work IOS by chance by running an abnormal config where the gateway address is omitted, and it doesn't appear to work at all on Android.
Reply
#15
That makes sense. I suppose there is a workaround on your mobile device anyway:

If you want to have Internet access while connected to Moode's SSID, you'll need to set a static IP (in the 192.168.168.2-254 range) without a default gateway or DNS servers. This will allow you to connect to the wireless with your Internet connection going out your cellular radio.

I took this instruction from an amazon review for the Sabrent Wifi Audio Receiver that has similar functionality. I'm not sure on the IP range from Moode's SSID, but it should be easy to figure out once you've joined it.
Reply
#16
You can use the settings from the screenshot in my original post - or just edit the dhcpd conf files like shown. It works fine.

It's not "by chance" it works on IOS. It's be design. :-)
Reply
#17
I'm doing a hardware workaround to this using a travel router. It basically gives a 2Ghz wifi SSID that has capability  to pass through an internet connection to those devices on that SSID. The connection can come from a wired cat cable or another wifi signal with the cellular connection (like a phone in hotspot mode). The pi and the controlling device like a tablet will then be on that HooToo SSID with full internet passthrough.

HooToo Travel Router

That version also runs a NAS/Samba/DLNA off the USB port. It's USB 5v powered so the pi will provide the power.
Reply
#18
I had this in my notes from a while back that is supposed to enable Router mode.

Code:
- Router mode
1) sudo nano /etc/sysctl.conf
delete the "#" on #net.ipv4.ip_forward=1
2) sudo iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
sudo sh -c "iptables-save > /etc/iptables.ipv4.nat"
3) sudo nano etc/rc.local
add the following above "exit 0"
iptables-restore < /etc/iptables.ipv4.nat
/etc/init.d/hostapd start
/etc/init.d/dnsmasq start
Reply
#19
You don’t need a gateway at all  - it’s just one broadcast domain. You’re not routing out of the ap, so no gateway is ever going to be needed
Reply
#20
@Zootalaws

Hello Mike ! long time no see..... has Borneo finally installed a connection ? Smile
Reply


Forum Jump: