Thank you for your donation!


UPnP playing from Qobuz App not working
#11
(12-14-2018, 09:40 AM)franz159 Wrote: Thanks, in https://www.lesbonscomptes.com/upmpdcli/downloads.html
I see listed three packages in the current version of upmpdcli

(1) libupnpp-0.16.1.tar.gz
(2) upmpdcli-1.3.8.tar.gz
(3) sc2mpd-1.1.5.tar.gz

While I understand (1) and (2) and they are present in Moode build recipe I'm not sure about what (3) is and if it is needed...

I believe sc2mpd is a Songcast listener for MPD. I have no experience with Songcast in any way, shape, or form.

Regards,
Kent
Reply
#12
@franz159

On an RPi3B+ running moOde r4.4, I downloaded three files from https://www.lesbonscomptes.com/upmpdcli/downloads (this is the "kitchen sink" directory!)
  • libupnp-1.6.25.tar.gz  (the build recipe specifies 1.6.20)
  • libupnpp-0.16.1.tar.gz  (the build recipe specifies 0.16.0; there's also a 0.17.0 which I'll try later)
  • upmpdcli-1.3.8.tar.gz  (the build recipe specifies 1.2.16)
Built and installed them in the same order as above. (Made no attempt to remove previous versions first.)

Rebooted and starting to test. 

From the command line,

Code:
pi@moode44:~ $ upmpdcli -v
Upmpdcli 1.3.8 libupnpp 0.16.1

So far, working with moOde from either BubbleUPnP or Bubble DS Next seems ok but I've only just begun pushing all the buttons, so to speak. I have Gmusic and Tidal accounts so can test those features. I don't have a Qobuz account so you're on your own there.

Regards,
Kent
Reply
#13
@TheOldPresbyope

Thanks!
Compiling right now....
Reply
#14
Progress report: Tidal worked right out of the box for me with this newer version of upmpdcli. Also, the newer version is working fine with the Linn Kinsky and Linn Kazoo apps on my iPad just as I reported for the apps on my Android devices.

As for Google Play Music, I seem to have borked my account credentials and can't get it work at the moment with either the newer (1.3.8) or the older (1.2.16) versions of upmpdcli. I need to back up and regroup.

Aside: the latest upmpdcli documentation specifically mentions that v1.3.x uses Python3 to access the gmusicapi so pip3 instead of pip has to be used to install it. The moOde image already includes Python3 but not pip3. Hence, installing gmusicapi involves


Code:
sudo apt-get install python3-pip
sudo pip3 install gmusicapi
 
Regards,
Kent
Reply
#15
(12-14-2018, 06:19 PM)TheOldPresbyope Wrote: @franz159

On an RPi3B+ running moOde r4.4, I downloaded three files from https://www.lesbonscomptes.com/upmpdcli/downloads (this is the "kitchen sink" directory!)
  • libupnp-1.6.25.tar.gz  (the build recipe specifies 1.6.20)
  • libupnpp-0.16.1.tar.gz  (the build recipe specifies 0.16.0; there's also a 0.17.0 which I'll try later)
  • upmpdcli-1.3.8.tar.gz  (the build recipe specifies 1.2.16)
Built and installed them in the same order as above. (Made no attempt to remove previous versions first.)

Rebooted and starting to test. 

From the command line,

Code:
pi@moode44:~ $ upmpdcli -v
Upmpdcli 1.3.8 libupnpp 0.16.1

So far, working with moOde from either BubbleUPnP or Bubble DS Next seems ok but I've only just begun pushing all the buttons, so to speak. I have Gmusic and Tidal accounts so can test those features. I don't have a Qobuz account so you're on your own there.

Regards,
Kent

(12-15-2018, 06:27 PM)franz159 Wrote: @TheOldPresbyope

Thanks!
Compiling right now....

Compiled and it runs, but the Qobuz app problem remains:

Code:
[size=small]MPD error[/size]
[size=small]Failed to decode http://streaming2.qobuz.com/file?uid=745401&eid=57423529&fmt=6&app_id=986445084&cid=563065&etsp=1549109151&hmac=y_muN1r5HoovwoXH1qNopF82nM0; CURL failed: The requested URL returned error: 403[/size]
Reply
#16
@franz159

Sorry, I've done what I can. I don't have a Qobuz account since they're still in closed beta-tester mode here in USA. 

So far as I can tell, the old and new versions of upmpdcli-related software are working for me with other, credentialed music accounts. (It's unclear to me if you have to enter Qobuz credentials into moOde if you're using a Qobuz app.)

I read the Qobuz posting that @jonners pointed to. At first blush, it doesn't seem relevant since it discusses whether a UPnP renderer can be visible to the Qobuz app, not whether credentials work properly. On the other hand, I didn't find any of the 'Qobuz and You' postings easy to understand.


You could try posting your problem to the Comment section of the upmpdcli site (https://www.lesbonscomptes.com/upmpdcli/); even better, to the ticket tracker they use (https://opensourceprojects.eu/p/upmpdcli/tickets/). 

Be sure you are clear about the software (what Qobuz app on what OS; moOde version; mpd version; upmpdcli-related versions; how you've entered your Qobuz account credentials), how you connected the app to moOde and what happened.

Good luck.

Regards,
Kent
Reply
#17
(12-14-2018, 06:19 PM)TheOldPresbyope Wrote: @franz159

On an RPi3B+ running moOde r4.4, I downloaded three files from https://www.lesbonscomptes.com/upmpdcli/downloads (this is the "kitchen sink" directory!)
  • libupnp-1.6.25.tar.gz  (the build recipe specifies 1.6.20)
  • libupnpp-0.16.1.tar.gz  (the build recipe specifies 0.16.0; there's also a 0.17.0 which I'll try later)
  • upmpdcli-1.3.8.tar.gz  (the build recipe specifies 1.2.16)
Built and installed them in the same order as above. (Made no attempt to remove previous versions first.)

Rebooted and starting to test. 

From the command line,

Code:
pi@moode44:~ $ upmpdcli -v
Upmpdcli 1.3.8 libupnpp 0.16.1

So far, working with moOde from either BubbleUPnP or Bubble DS Next seems ok but I've only just begun pushing all the buttons, so to speak. I have Gmusic and Tidal accounts so can test those features. I don't have a Qobuz account so you're on your own there.

Regards,
Kent

(02-02-2019, 01:18 PM)TheOldPresbyope Wrote: @franz159

Sorry, I've done what I can. I don't have a Qobuz account since they're still in closed beta-tester mode here in USA. 

So far as I can tell, the old and new versions of upmpdcli-related software are working for me with other, credentialed music accounts. (It's unclear to me if you have to enter Qobuz credentials into moOde if you're using a Qobuz app.)

I read the Qobuz posting that @jonners pointed to. At first blush, it doesn't seem relevant since it discusses whether a UPnP renderer can be visible to the Qobuz app, not whether credentials work properly. On the other hand, I didn't find any of the 'Qobuz and You' postings easy to understand.


You could try posting your problem to the Comment section of the upmpdcli site (https://www.lesbonscomptes.com/upmpdcli/); even better, to the ticket tracker they use (https://opensourceprojects.eu/p/upmpdcli/tickets/). 

Be sure you are clear about the software (what Qobuz app on what OS; moOde version; mpd version; upmpdcli-related versions; how you've entered your Qobuz account credentials), how you connected the app to moOde and what happened.

Good luck.

Regards,
Kent
Thanks Ken, I will follow your advice!
Reply


Forum Jump: