Thank you for your donation!


Moodeaudio Last.fm Scrobbler issue
#1
Hi Moodeaudio team,

I finally moved from Runeaudio to Moodeaudio, and so far happy with the quality. Only problem is that I cannot get Last.fm scrobbler to work. I have of course provided name/password into the right config section, and double checked and also rebooted several times. However it does not give updates to Last.fm. This was working with Runeaudio, so it is not a last.fm issue, but I hate to go back to Runeaudio only for this.

Please let me know how I can debug this issue, or what other settings in Moodeaudio should be turned on to make this work

Thanks for update
Flex
Reply
#2
Just ran a quick test and its working fine on my end.

You can troubleshoot by verifying its running and seeing of there is anything odd in its config file

Code:
pgrep mpdas

cat /usr/local/etc/mpdasrc
Reply
#3
Hi Tim,
thanks, sorry for late response. I was back to Runeaudio, but trying now again.
Scrobbler still not working in moode (in Runeaudio not a problem).
I see in Debug that scrobbler is started. Should I already see something in Last.fm after one song, or does it consolidate first several songs before sending to Last.fm?
Your suggestion, the command line checks, how can I do this? Do I need to log into moode via tty?
Last question: besides Scrobbler account, do I need another service feature enabled in moode. to make this working?
thanks for more help
Flex
Reply
#4
The scrobbler works as expected in my installation, scrobbling almost instantly each track to last.fm. Nothing else needs to be configured other than enabling the scrobbler in the audio settings and setting username and password.
Reply
#5
(12-25-2018, 12:28 PM)nassost Wrote: The scrobbler works as expected in my installation, scrobbling almost instantly each track to last.fm. Nothing else needs to be configured other than enabling the scrobbler in the audio settings and setting username and password.

That is what I did, several times checked. In Runeaudio this works, but via Moode audio I do not see any update in Last.fm.
I have a clear installation of Moode 4.4, nothing special, just playing NAS files, similar what I did in Runeaudio

What could I check further?
Reply
#6
do I need to do anything in Last.fm? add  Moode as application?
Reply
#7
No, you don't have to do anything in Last.fm. My best guess, and excuse me for pointing out something so obvious, would be to double check you input the correct password.
Reply
#8
sure, only done 5 times :-)    Still not working

So, back to Runeaudio .....   i guess, i will never know why it did not want to work
Reply
#9
(12-26-2018, 09:35 PM)flexmens Wrote: sure, only done 5 times :-)    Still not working

So, back to Runeaudio .....   i guess, i will never know why it did not want to work

Hi, @flexmens

You never got back to Tim with the responses to the two command-line queries he posted. You can use the Open Web SSH Terminal capability built into moOde or ssh into moOde from another host.

Candidly, I don't have any use for Last.FM and scrobbling but I keep an account some time ago so I can test the feature in moOde.

Once I turned on the  service via m>Config>Audio>Services>Audio scrobbler, here's what I see in response to Tim's suggested commands (this in moOde r4.4 but the service has been included since r2.6 according to the release notes):

Code:
pi@moode:~ $ pgrep mpdas
1145   <<< proves the process is running; this is its PID
pi@moode:~ $ cat /usr/local/etc/mpdasrc
#########################################
# This file is automatically generated by
# the player System configuration page.
#########################################

username = myUsername    <<< naturally I don't show my
password = myPassword    <<< actual credentials
runas = mpd
debug = 0

Do you get these responses and are the credentials in mpdasrc correct?

With the service enabled, Last.FM started logging my plays. Easy peasy.
Regards,
Kent
Reply
#10
(12-26-2018, 10:17 PM)TheOldPresbyope Wrote:
(12-26-2018, 09:35 PM)flexmens Wrote: sure, only done 5 times :-)    Still not working

So, back to Runeaudio .....   i guess, i will never know why it did not want to work

Hi, @flexmens

You never got back to Tim with the responses to the two command-line queries he posted. You can use the Open Web SSH Terminal capability built into moOde or ssh into moOde from another host.

Candidly, I don't have any use for Last.FM and scrobbling but I keep an account some time ago so I can test the feature in moOde.

Once I turned on the  service via m>Config>Audio>Services>Audio scrobbler, here's what I see in response to Tim's suggested commands (this in moOde r4.4 but the service has been included since r2.6 according to the release notes):

Code:
pi@moode:~ $ pgrep mpdas
1145   <<< proves the process is running; this is its PID
pi@moode:~ $ cat /usr/local/etc/mpdasrc
#########################################
# This file is automatically generated by
# the player System configuration page.
#########################################

username = myUsername    <<< naturally I don't show my
password = myPassword    <<< actual credentials
runas = mpd
debug = 0

Do you get these responses and are the credentials in mpdasrc correct?

With the service enabled, Last.FM started logging my plays. Easy peasy.
Regards,
Kent



Thanks, I will try tonight
Reply


Forum Jump: