Thank you for your donation!


Solved: HELP - RPi 3b + and MoOde Audio 4.1
#1
Bought a Raspberry Pi 3B + and now I'm trying to install MoOda Audio version 4.1.  I changed the wi-fi country code but, I get the following in Terminal when I run "mosbrief":

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Apr 14 20:34:23 2018 from 192.168.200.23
pi@moode:~ $ mosbrief
// STEP 2 - Direct build so no need to expand Root partition
// STEP 3A - Install core packages
// STEP 3B - Install core packages
** Error: Install failed
** Error: image build exited
** Error: reboot to resume the build
** Error: should never arrive at case = *
** Error: should never arrive at case = *
** Error: should never arrive at case = *
** Error: should never arrive at case = *

I rebooted but I get the same thing again, and again,...???
Reply
#2
(04-15-2018, 12:48 AM)jrocker Wrote: Bought a Raspberry Pi 3B + and now I'm trying to install MoOda Audio version 4.1.  I changed the wi-fi country code but, I get the following in Terminal when I run "mosbrief":

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Apr 14 20:34:23 2018 from 192.168.200.23
pi@moode:~ $ mosbrief
// STEP 2 - Direct build so no need to expand Root partition
// STEP 3A - Install core packages
// STEP 3B - Install core packages
** Error: Install failed
** Error: image build exited
** Error: reboot to resume the build
** Error: should never arrive at case = *
** Error: should never arrive at case = *
** Error: should never arrive at case = *
** Error: should never arrive at case = *

I rebooted but I get the same thing again, and again,...???

Sounds like it is failing to connect to the internet.  Could you put the moslog instead the brief?
Reply
#3
(04-15-2018, 02:48 PM)RafaPolit Wrote:
(04-15-2018, 12:48 AM)jrocker Wrote: Bought a Raspberry Pi 3B + and now I'm trying to install MoOda Audio version 4.1.  I changed the wi-fi country code but, I get the following in Terminal when I run "mosbrief":

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Apr 14 20:34:23 2018 from 192.168.200.23
pi@moode:~ $ mosbrief
// STEP 2 - Direct build so no need to expand Root partition
// STEP 3A - Install core packages
// STEP 3B - Install core packages
** Error: Install failed
** Error: image build exited
** Error: reboot to resume the build
** Error: should never arrive at case = *
** Error: should never arrive at case = *
** Error: should never arrive at case = *
** Error: should never arrive at case = *

I rebooted but I get the same thing again, and again,...???

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Apr 14 21:18:55 2018 from 192.168.200.23
pi@moode:~ $ moslog
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
** Error: Install failed
** Error: image build exited
** Error: reboot to resume the build
** Error: should never arrive at case = *
** Error: should never arrive at case = *
** Error: should never arrive at case = *
** Error: should never arrive at case = *
** Error: should never arrive at case = *
** Error: should never arrive at case = *

Sounds like it is failing to connect to the internet.  Could you put the moslog instead the brief?
Reply
#4
Also, I read the build recipe, version 2.4...

I did not do the following:

8. Edit the file named cmdline.txt

# Remove the text below 
quiet init=/usr/lib/raspi-config/init_resize.sh

# Add this text to beginning of the line. Ensure there is a space between this text and the remaining text.
net.ifnames=0

And, frankly, this is a bit cryptic for me, particularly exactly what I need to do in the second part, as to the space etc.?
Reply
#5
Hi,

When you are performing a Direct Build just boot up fresh Raspbian Lite that has SSH enabled, then download and run the Builder, and follow the instructions that appear on the SSH terminal. Nothing has to be manually edited or changed.

The Builder will automatically reboot many times during the main part of the Build. While its rebooting you won't be able to connect via SSH. Just wait a bit and try again. If mosbrief shows a failure at any point in the Build along with the line "** Error: reboot to resume the build" just "sudo reboot", wait a while then check mosbrief again.

Whatever you do don't manually reboot while the Build is running or it will be broken.

-Tim
Reply
#6
Restarted the build from scratch and it now is up and running.  BTW, I think the Raspberry Pi 3B + is a bit better sonically.
Reply
#7
Nice :-)
Reply
#8
Thats great. Nice to see that your problem was resolved.

Please if you can edit your first post and change prefix of this thread to [SOLVED]

Thank you
Reply


Forum Jump: