Thank you for your donation!


Solved: Random button doesn't randomize...
#1
I'm not sure if I had this from the beginning of 4.1 but the random button doesn't do anything, except for activating the Auto-Shuffle.
Anyone else with this problem?

J


BTW: awfully quiet in here :-(
Bad sound + Publicity kills good music/forum
RPI3+ Allo Katana + Isolator (SQ) | 2x AudioPhonics LPSU25 | NAD C368 + BluOS module | BeyerDynamic DT 1770 Pro | Synology DS712+ with DX513 (30T)
Reply
#2
(04-15-2018, 07:38 PM)JST1963 Wrote: I'm not sure if I had this from the beginning of 4.1 but the random button doesn't do anything, except for activating the Auto-Shuffle.
Anyone else with this problem?

J


BTW: awfully quiet in here :-(

The Random button just activates Autoshuffle, providing you have enabled Autoshuffle in MPD settings on the Audio config page. Consume mode should also turn on when Autoshuffle is selected.
Yes it is rather quiet here.
Reply
#3
(04-15-2018, 08:15 PM)BackinBlack Wrote:
(04-15-2018, 07:38 PM)JST1963 Wrote: I'm not sure if I had this from the beginning of 4.1 but the random button doesn't do anything, except for activating the Auto-Shuffle.
Anyone else with this problem?

J


BTW: awfully quiet in here :-(

The Random button just activates Autoshuffle, providing you have enabled Autoshuffle in MPD settings on the Audio config page. Consume mode should also turn on when Autoshuffle is selected.
Yes it is rather quiet here.

Well, that was not the case with earlier versions, if I'm not mistaken.
Even when there was a playlist, it used to randomize this list.

J
Bad sound + Publicity kills good music/forum
RPI3+ Allo Katana + Isolator (SQ) | 2x AudioPhonics LPSU25 | NAD C368 + BluOS module | BeyerDynamic DT 1770 Pro | Synology DS712+ with DX513 (30T)
Reply
#4
@BackinBlack is correct. Its been that way since auto-shuffle was introduced back in the moOde 3 series.

If you want to randomize just the items in the Playlist, then turn off Auto-shuffle in Audio config. The Random button will then activate normal MPD random play.

-Tim
Reply
#5
(04-15-2018, 09:25 PM)Tim Curtis Wrote: @BackinBlack is correct. Its been that way since auto-shuffle was introduced back in the moOde 3 series.

If you want to randomize just the items in the Playlist,  then turn off Auto-shuffle in Audio config. The Random button will then activate normal MPD random play.

-Tim

Hmmm....Auto-shuffle ON or OFF, there is no random play of my playlist.... Sad

CORRECTION: Restart of the RPI solved the problem
Bad sound + Publicity kills good music/forum
RPI3+ Allo Katana + Isolator (SQ) | 2x AudioPhonics LPSU25 | NAD C368 + BluOS module | BeyerDynamic DT 1770 Pro | Synology DS712+ with DX513 (30T)
Reply
#6
Just ran a quick test and no issues on my end. When a track in the Playlist finishes, MPD starts playing a randomly chosen track in the Playlist.

-Tim
Reply
#7
Tim, we crossed each other with our postings. I corrected mine: a restart was needed...

J
Bad sound + Publicity kills good music/forum
RPI3+ Allo Katana + Isolator (SQ) | 2x AudioPhonics LPSU25 | NAD C368 + BluOS module | BeyerDynamic DT 1770 Pro | Synology DS712+ with DX513 (30T)
Reply
#8
No prob. Shouldn't need a reboot though, but in either case your issue is solved :-)
Reply


Forum Jump: