Thank you for your donation!


Problem: HDMI port resolution
#1
Can anybody tell me what the resolution on the HDMI port is? Is it always 1920x1080 (or 1920x1200)? Can you change it to something else?
And if so, how?
I'm asking this because I had an RPI configured with moOde at home. During the configuration I connected a Samsung 24" Full HD monitor to the HDMI port.
After I finished setting up the whole thing, I disconnected the RPI and took it to the office where I connected it to a "non-FullHD" monitor. The resolution was 1680x1050. And now nothing was shown on that monitor, music was played (thanks to the "Autoplay after start") but nothing was shown, only a black screen. When I connected it again to another FullHD screen , the UI of moOde was displayed again.
So, is it possible to change the resolution so I can still use that "old" 1680by1050 monitor.

Thx,
JST
Bad sound kills good music
RPi 3B+  |  Allo Katana with Isolator (SQ)  |  2x AudioPhonics LPSU25  |  Denon DRA-100  |  BeyerDynamic DT 1770 Pro  |  Synology DS712+ with DX513
Reply
#2
There is no fixed resolution for the HDMI port. An attempt to dynamically determine the resolution of HDMI attached monitor is made by some code in the X11 display server startup script /home/pi/.xinitrc. This resolution is then used to set the Window size for Chrome Browser when its launched.

Some monitors might not report the correct resolution. YMMV. In this case I think there are some manual settings that can be made in /boot/config.txt but I have no idea what they might be.

Here is the .xinitrc script

Code:
# Turn off display power management
xset -dpms
# Screensaver timeout in secs or 'off' for no timeout
xset s 600

# launch chrome browser
SCREENSIZE="$(fbset -s | awk '$1 == "geometry" { print $2","$3 }')"
chromium-browser --kiosk --touch-events --disable-touch-drag-drop \
--enable-touchview --enable-pinch --window-size=$SCREENSIZE --window-position=0,0 \
--disable-session-crashed-bubble --disable-infobars --no-first-run --app=http://localhost/

And here is what is returned for SCREENSIZE after I connect to my 24" 1920x1200 ASUS panel and then reboot.

Code:
pi@rp3:~ $ fbset -s | awk '$1 == "geometry" { print $2","$3 }'
1920,1200

-Tim
Reply
#3
I'll give it a try tomorrow at the office :-)

Thx!
J
Bad sound kills good music
RPi 3B+  |  Allo Katana with Isolator (SQ)  |  2x AudioPhonics LPSU25  |  Denon DRA-100  |  BeyerDynamic DT 1770 Pro  |  Synology DS712+ with DX513
Reply
#4
Tim,
At the office today I tried lots of things, also other stuff I found on the internet (if my boss only knew I was playing with moOde and an RPi....)
Nothing really helped. But then I clicked on some button of the monitor itself you change some parameter (input and so on) and that button didn't react. In fact, none of the buttons responded to a push, only the on/off button. So I guess the monitor is f**k*d u* (read: broken).
So, let me try again on Wednesday with another (old) 1680by1050monitor. I'll keep you informed.

Johan
Bad sound kills good music
RPi 3B+  |  Allo Katana with Isolator (SQ)  |  2x AudioPhonics LPSU25  |  Denon DRA-100  |  BeyerDynamic DT 1770 Pro  |  Synology DS712+ with DX513
Reply
#5
(04-16-2018, 05:52 PM)JST1963 Wrote: Tim,
At the office today I tried lots of things, also other stuff I found on the internet (if my boss only knew I was playing with moOde and an RPi....)
Nothing really helped. But then I clicked on some button of the monitor itself you change some parameter (input and so on) and that button didn't react. In fact, none of the buttons responded to a push, only the on/off button. So I guess the monitor is f**k*d u* (read: broken).
So, let me try again on Wednesday with another (old) 1680by1050monitor. I'll keep you informed.

Johan

Hi, Johan.

I looked up the fbset command used in the .xinitrc script. The man page says 
Quote:fbset  uses  an own video mode database located in /etc/fb.modes. An unlimited number of video modes can be defined in this database. For further information see fb.modes(5).

Your 1680x1050 resolution isn't defined in fb.modes as distributed but you could define it yourself.

I'm presupposing that raspbian uses some variation of VESA EDID via HDMI to detect the monitor's capabilities and then compares that with the fb.modes data.

Regards,
Kent
Reply
#6
1680x1050 in configs here Kent.. #57 thru #59 ;-).....https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

Setup configs here...https://www.raspberrypi.org/documentation/configuration/config-txt/README.md


maybe set manually in /boot/config.txt

hdmi_drive=1
# Set monitor mode
hdmi_group=2
# Set monitor resolution to 1680x1050 60Hz
hdmi_mode=58
Reply
#7
(04-17-2018, 07:39 PM)DRONE7 Wrote: 1680x1050 in configs here Kent..  #57 thru #59 ;-).....https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

Setup configs here...https://www.raspberrypi.org/documentation/configuration/config-txt/README.md


maybe set manually in /boot/config.txt

hdmi_drive=1
# Set monitor mode
hdmi_group=2
# Set monitor resolution to 1680x1050 60Hz
hdmi_mode=58

I have tried this but without a positive result.
In my case the hdmi_drive parameter was already there except that it was set at 2.
The other two (hdmi_group and hdmi_mode) were added, then rebooted the thingie, but screen stayed black.

Tomorrow I will go back to the office (home-work today), and then I'll try another monitor first.
One thing though, the Pi is connected to the monitor via a HDMI to DVI cable. I don't know if that's important. Monitor only has VGA and DVI connections.
Crossing fingers....

Johan
Bad sound kills good music
RPi 3B+  |  Allo Katana with Isolator (SQ)  |  2x AudioPhonics LPSU25  |  Denon DRA-100  |  BeyerDynamic DT 1770 Pro  |  Synology DS712+ with DX513
Reply
#8
(04-17-2018, 07:39 PM)DRONE7 Wrote: 1680x1050 in configs here Kent..  #57 thru #59 ;-).....https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

Setup configs here...https://www.raspberrypi.org/documentation/configuration/config-txt/README.md


maybe set manually in /boot/config.txt

hdmi_drive=1
# Set monitor mode
hdmi_group=2
# Set monitor resolution to 1680x1050 60Hz
hdmi_mode=58
Thanks for that, @DRONE7. Curious, though, that the raspbian config.txt and the /etc/fb.modes file in raspbian aren't better aligned in terms of resolution choices.
Regards,
Kent
Reply


Forum Jump: