Thank you for your donation!


MoOde 4.1 & Rpi 3 B+, no Access Point
#1
Hi, I have installed 4.1 on a Raspberry 3 B+. All works right, but wifi got me some problems. Not working at all, I was able to run wlan0 but Access Point does not appear.

Thanks
Steve
Reply
#2
Please make sure you change 'Country code' first under wifi settings
Reply
#3
I'm wondering about this as well. I'm on a wired network, but want to make the RPi an access point so I can remotely control MoOde from my iPhone. As a side note: Because the Static eth0 configuration doesn't include the netmask of my network - 255.255.255.192 I had to use /etc/network/interfaces to set up my static IP. Would this prevent the AP from working? I'm on a RPi 3 B+ as well.

I'm also using US as my country code.
Reply
#4
Hi @Mullet,

AP mode is not started if there is an Ethernet connection because there is no need for two active network interfaces. You can just access moOde UI over the Ethernet connection or alternatively boot up w/o Ethernet and then AP mode should be activated.

Whats the usage scenario for that particular net mask?

-Tim
Reply
#5
I'm on a private corporate network where we split it into 4 subnets hence 255.255.255.192. When I put in any data in the network section it overwrites my /etc/network/interfaces file. I'm suspecting this is because with Stretch there is a different way of handling networking. I tried dhcpcd.conf earlier on and I couldn't get a static ip to work.

For some reason I thought the AP feature would "extend" a network e.g. my wifi shares my ethernet network per se. I know this is possible because I've done it with a beaglebone enhanced and Debian Jessie.

Interesting that it is one or the other.

Thanks,
Mullet
Reply
#6
Checked for the moode wifi network with no ethernet plugged in and it works!

One use case for both wifi and ethernet is if your library is on a NAS but you want to control from iPhone/Android etc.
Reply
#7
The networking is designed around the assumption that a typical residential WiFi Router is present. In this scenario you can connect Pi via Ethernet or WiFi to Router and access moOde via Wifi from clients, or via Ethernet if client is connected to Router via Ethernet. If no WiFi is present then AP mode is activated providing there is no Ethernet connection.

Corporate Wireless networks are another matter altogether since they usually restrict what is allowed to connect, and have other configuration requirements.

If you want to use your custom net mask then first set a static address in Network Config then APPLY, then edit /etc/dhcpcd.conf and replace /24 with /26 which will yield 255.255.255.192 net mask. NOTE: networking in Raspbian Stretch is controlled by dhcpcd and wpa_supplicant. The /etc/network/interfaces file is just a stub and is not used.

/etc/dhcpcd.conf 
#########################################
# This file is automatically generated by
# the player Network configuration page.
#########################################

hostname
clientid
persistent
option rapid_commit
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
option ntp_servers
option interface_mtu
require dhcp_server_identifier
slaac private
interface eth0
static ip_address=192.168.1.22/24
static routers=192.168.1.1
static domain_name_servers=192.168.1.1
#AP mode
#interface wlan0
#static ip_address=172.24.1.1/24
#nohook wpa_supplicant

-Tim
Reply
#8
Hi,

first of all:
Thank you Tim (and all his contributors) for this great piece of software!

I've been a Moode-User since version 2.4 an have been reading every single post in the diyaudio-Moode-thread.

The AP-Mode with active ethernet connection has been requestet for several times.
It would be great, if the AP-Mode would be a real Access-Point.
I use Moode as a real Access-Point since version 2.7.

With the following steps i've got it working in Moode 4.1 on a Raspberry Pi 3B with internal WiFi:
Code:
sudo systemctl stop hostapd
sudo systemctl stop dnsmasq
sudo nano /etc/dhcpcd.conf
Insert the following above "#AP-Mode"
Quote:interface wlan0
static ip_address=10.0.0.1/24
nohook wpa_supplicant
I prefer this IP and Subnet. Maybe the name off the interface is another if an dedicated WiFi is used.
Code:
sudo nano /etc/dnsmasq.conf
Uncomment all lines and add
Quote:interface=wlan0
dhcp-range=10.0.0.101,10.0.0.200,255.255.255.0,24h

Code:
sudo nano /etc/hostapd/hostapd.conf
This step is only necessary if you want to change the SSID, the WiFi-Key or the used channel.
Code:
sudo nano /etc/sysctl.conf
delete the "#" on #net.ipv4.ip_forward=1
Code:
sudo iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
sudo sh -c "iptables-save > /etc/iptables.ipv4.nat"

Code:
sudo nano /etc/rc.local
add the following abov "exit 0"
Quote:iptables-restore < /etc/iptables.ipv4.nat
/etc/init.d/hostapd start
/etc/init.d/dnsmasq start

Reboot.

Maybe something like this could be integrated in moode by default?
Reply
#9
Hi,

Whats the usage scenario?

My concern in implementing this is the additional support vector it creates.

-Tim
Reply
#10
This seems to be exactly what I was asking about but didn't really articulate it well.

Main usage case: control via mobile phone or tablet, but also be connected to ethernet for NAS connectivity.

I'd also use this to send audio via AirPlay vs. Bluetooth.

Thanks @psychofaktory !
Reply


Forum Jump: