Thank you for your donation!


DNS problem with Tidal
#1
I have version 4.4 (in place update), on wired lan. When I try to play Tidal songs
from BubbleUPnP, I get MPD error Failed to decode http://192.168.100.20:49149/tidal/track?...Id=1550546; CURL failed: Failed to connect to 192.168.100.20 port 49149: Connection refused

Before the update I had this error MPD error Failed to decode http://192.168.100.20:49149/tidal/track?...Id=1550546; CURL failed: Could not resolve host: ab-pr-ak.audio.tidal.com

I tried pinging from ssh but I got

Code:
pi@moode:~ $ ping ab-pr-ak.audio.tidal.com
ping: ab-pr-ak.audio.tidal.com: Name or service not known

The windows computer on my network pings tidal fine.

Also
Code:
pi@moode:~ $ dig @62.162.32.165 ab-pr-ak.audio.tidal.com

; <<>> DiG 9.10.3-P4-Raspbian <<>> @62.162.32.165 ab-pr-ak.audio.tidal.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25346
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 13, ADDITIONAL: 16

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;ab-pr-ak.audio.tidal.com.      IN      A

;; ANSWER SECTION:
ab-pr-ak.audio.tidal.com. 300   IN      CNAME   ab-pr-ak.audio.tidal.akadns.net.
ab-pr-ak.audio.tidal.akadns.net. 30 IN  CNAME   eip4ab-pr-ak.audio.tidal.com.edgekey.net.
eip4ab-pr-ak.audio.tidal.com.edgekey.net. 5104 IN CNAME eip4ab-pr-ak.audio.tidal.com.eip.akadns.net.
eip4ab-pr-ak.audio.tidal.com.eip.akadns.net. 300 IN CNAME eip-ntt.eip4ab-pr-ak.audio.tidal.com.akahost.net.
eip-ntt.eip4ab-pr-ak.audio.tidal.com.akahost.net. 30 IN A 2.18.49.13

;; AUTHORITY SECTION:
akahost.net.            60572   IN      NS      a11-65.akam.net.
akahost.net.            60572   IN      NS      a1-65.akam.net.
akahost.net.            60572   IN      NS      a9-65.akam.net.
akahost.net.            60572   IN      NS      a16-65.akam.net.
akahost.net.            60572   IN      NS      a5-65.akam.net.
akahost.net.            60572   IN      NS      a20-65.akam.net.
akahost.net.            60572   IN      NS      a7-65.akam.net.
akahost.net.            60572   IN      NS      a18-65.akam.net.
akahost.net.            60572   IN      NS      a3-65.akam.net.
akahost.net.            60572   IN      NS      a13-65.akam.net.
akahost.net.            60572   IN      NS      a6-65.akam.net.
akahost.net.            60572   IN      NS      a28-65.akam.net.
akahost.net.            60572   IN      NS      a12-65.akam.net.

;; ADDITIONAL SECTION:
a1-65.akam.net.         67202   IN      A       193.108.91.65
a3-65.akam.net.         2860    IN      A       96.7.49.65
a3-65.akam.net.         67921   IN      AAAA    2600:1408:1c::41
a5-65.akam.net.         28822   IN      A       95.100.168.65
a6-65.akam.net.         51371   IN      A       23.211.133.65
a7-65.akam.net.         2381    IN      A       23.61.199.65
a9-65.akam.net.         3379    IN      A       184.85.248.65
a9-65.akam.net.         67921   IN      AAAA    2a02:26f0:117::41
a11-65.akam.net.        1126    IN      A       84.53.139.65
a12-65.akam.net.        55413   IN      A       184.26.160.65
a13-65.akam.net.        55285   IN      A       2.22.230.65
a16-65.akam.net.        1994    IN      A       23.211.132.65
a18-65.akam.net.        9678    IN      A       95.101.36.65
a20-65.akam.net.        1539    IN      A       95.100.175.65
a28-65.akam.net.        62761   IN      A       95.100.173.65

;; Query time: 461 msec
;; SERVER: 62.162.32.165#53(62.162.32.165)
;; WHEN: Tue Jan 01 19:03:19 EST 2019
;; MSG SIZE  rcvd: 807

where 62.162.32.165 is the DNS server from my internet provider

and
Code:
pi@moode:~ $ cat /etc/resolv.conf
# Generated by resolvconf
nameserver 192.168.100.1


Tidal username and password are ok and I tried rebooting the rooter. Can anyone help?
Reply
#2
The symptom "ping: ab-pr-ak.audio.tidal.com: Name or service not known" suggests some sort of local network issue.

No issues resolving the host on my end.
Code:
pi@rp3:~ $ ping ab-pr-ak.audio.tidal.com
PING eip-ntt.eip4ab-pr-ak.audio.tidal.com.akahost.net (2.18.49.13) 56(84) bytes of data.
64 bytes from a2-18-49-13.deploy.static.akamaitechnologies.com (2.18.49.13): icmp_seq=1 ttl=57 time=19.6 ms
64 bytes from a2-18-49-13.deploy.static.akamaitechnologies.com (2.18.49.13): icmp_seq=2 ttl=57 time=18.1 ms
64 bytes from a2-18-49-13.deploy.static.akamaitechnologies.com (2.18.49.13): icmp_seq=3 ttl=57 time=19.3 ms
64 bytes from a2-18-49-13.deploy.static.akamaitechnologies.com (2.18.49.13): icmp_seq=4 ttl=57 time=21.1 ms
^C
--- eip-ntt.eip4ab-pr-ak.audio.tidal.com.akahost.net ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3003ms
rtt min/avg/max/mdev = 18.177/19.588/21.178/1.070 ms
pi@rp3:~ $
Reply
#3
@nikigo

Let's stay focused on what you have now
Code:
I have version 4.4 (in place update), on wired lan. When I try to play Tidal songs
from BubbleUPnP, I get MPD error Failed to decode http://192.168.100.20:49149/tidal/track?...Id=1550546; CURL failed: Failed to connect to 192.168.100.20 port 49149: Connection refused

That means MPD couldn't get a response on port 49149 from upmpdcli on your moOde player (which I assume is at 192.168.100.20). 
Here's the ports being listened to by upmpdcli on my player as I play a Tidal track:
Code:
pi@moode:~ $ sudo netstat -tulpn|grep upmpdcli
tcp        0      0 192.168.1.182:49153     0.0.0.0:*               LISTEN      1229/upmpdcli      
tcp        0      0 0.0.0.0:49149           0.0.0.0:*               LISTEN      1229/upmpdcli      
tcp        0      0 192.168.1.182:49152     0.0.0.0:*               LISTEN      1174/upmpdcli      
udp        0      0 0.0.0.0:1900            0.0.0.0:*                           1229/upmpdcli      
udp        0      0 0.0.0.0:1900            0.0.0.0:*                           1174/upmpdcli      
udp        0      0 127.0.0.1:39521         0.0.0.0:*                           1174/upmpdcli      
udp        0      0 127.0.0.1:40103         0.0.0.0:*                           1229/upmpdcli    

Is upmpdcli running on your player?
Regards,
Kent
Reply
#4
(01-02-2019, 05:29 PM)TheOldPresbyope Wrote: @nikigo

Let's stay focused on what you have now

Sorry, later on I realized I still have the "Could not resolve host: ab-pr-ak.audio.tidal.com" error, as well.

Quick update of what I realized. I removed resolvconf and entered this
Code:
sudo ln -sf /run/resolvconf/resolv.conf /etc/resolv.conf
sudo sh -c 'echo "nameserver 8.8.8.8" >> /etc/resolv.conf'

I was able to play a track from Tidal and I was able to ping. However a reboot overwrites the resolv.conf and then nameserver is back to the router ip and it's not working anymore. It resolves other addresses but not tidal. It works only if the router ip is removed as a nameserver. Other computers and android devices ping the tidal address so I guess the router dns is fine. Something with my network settings on raspbian is broken. Noob here so I would need more help in what other info you need, so you can help me.

Here is what ports are listened while I was able to play a tidal
Code:
pi@moode:~ $ pi@moode:~ $ sudo netstat -tulpn|grep upmpdcli
tcp        0      0 192.168.100.20:49152    0.0.0.0:*               LISTEN      756/upmpdcli
tcp        0      0 192.168.100.20:49153    0.0.0.0:*               LISTEN      786/upmpdcli
udp        0      0 127.0.0.1:35065         0.0.0.0:*                           756/upmpdcli
udp        0      0 127.0.0.1:52541         0.0.0.0:*                           786/upmpdcli
udp        0      0 0.0.0.0:1900            0.0.0.0:*                           786/upmpdcli
udp        0      0 0.0.0.0:1900            0.0.0.0:*                           756/upmpdcli
Reply
#5
I'm on the way out the door so only two quick comments.

1) moOde picks up the DNS server address from your router as part of the DHCP process. It's very common for the router (192.168.100.1, in your case) to run a local DNS server. It should be passing the (unknown to it) Tidal server name up the chain to your ISP's DNS. Offhand, I don't have an explanation to offer why this isn't working.

You could try working around your problem by choosing STATIC IP, which allows you to set primary and secondary DNS addresses. 

2) Testing with android devices doesn't count. Google's DNS service is hardcoded into them.

Regards,
Kent
Reply
#6
(01-02-2019, 07:09 PM)TheOldPresbyope Wrote: You could try working around your problem by choosing STATIC IP, which allows you to set primary and secondary DNS addresses. 

Does not work with my internet provider's dns, only with 8.8.8.8 as secondary dns. This works for now. Thanks Kent.
Reply


Forum Jump: