Thank you for your donation!


Instruction Guide Solve AirPlay disconnecting and disappearing immediately with some USB DACs
#1
When using some USB DACs connected to the Raspberry Pi (list below), shairplay-sync (the software that acts as the Airplay receiver in MoOde) encounters a fatal error shortly after a connection is made, before any audio can be played. This results in the MoOde device disappearing from the list of available airplay devices on clients until the airplay receiver is restarted from MoOde’s Configure > Audio.

List of known affected devices and bit depth/sample rate to use (reply to thread with additions)
  • Peachtree Nova 150, USB2.0 mode. Confirmed working: 32bit/44.1kHz
  • Chord Mojo. Reported working: 32bit/44.1kHz (see here)

Solution

  1. Go to MoOde’s Configure > Audio page. Scroll to Renderers > Airplay, and click Configure Airplay.
  2. Then edit the field for output bit depth from shairplay-sync, to the maximum supported by your DAC (see below, or your DAC’s specs). Even if your DAC is meant to support 16bit/44.1kHz, this has been known to cause the error anyway.
  3. Tap Apply at the top of the page to restart the Airplay Receiver with the new settings, and try streaming content from an airplay client again.
  4. If the receiver still crashes and disappears, try increasing the sample rate to the maximum supported by your DAC also.
  5. Reply to this thread with confirmed working settings.

Error as shown in /var/log/shairport-sync.log

Quote:...
audio_alsa: Sample format 2 not available for device "hw:1": Invalid argument
...
Sample format number and device name depend on your configuration.
Reply


Forum Jump: