Thank you for your donation!


moOde doesn't see files on NAS, but linux does
#1
Hi
I run rpi2B, moode v4.4 (ISO -> uSD) + QNAP NAS
I have added NAS and it is connected, but moode doesn't see any files.
I noticed, while I connect via SSH, that remote folder is mounted, but only root can access it. I even added pi to root usergroup.
BUT
I have made update in settings and now:
- NAS doesn't show up in "Music", but is connected in sources. It show up if I remove it and add again.
- still no files in NAS folder in "Music"
- via SSH I can access mounted folder as user pi

I'm really not linux user, so hope that there is easy answer to make it work Smile
Reply
#2
If the mount was successful and MPD database update ran then examine the MPD log for errors

cat /var/log/mpd/log
Reply
#3
log
Code:
Jan 13 19:07 : exception: Failed to open /var/lib/mpd/music/NAS/Muzyka: Permission denied
Jan 13 19:42 : exception: Failed to open /var/lib/mpd/music/NAS/Muzyka: Permission denied
Jan 13 19:47 : exception: Failed to open /var/lib/mpd/music/NAS/muzyka: Permission denied
Reply
#4
Any suggestions on that?
I have standard Moode ISO, no changes in users or groups.
I have added pi user to root group and pi can see files, but what user is running moode application?
Reply
#5
(01-14-2019, 04:36 PM)lukas12p Wrote: Any suggestions on that?
I have standard Moode ISO, no changes in users or groups.
I have added pi user to root group and pi can see files, but what user is running moode application?

@lukas12p

None of this is necessary. You can do all your NAS configuration from the moOde UI. 

Clicking through the sequence m>Configure>Sources>CREATE NAS source will get you to the NAS source page.

Regards,
Kent
Reply
#6
(01-14-2019, 04:43 PM)TheOldPresbyope Wrote:
(01-14-2019, 04:36 PM)lukas12p Wrote: Any suggestions on that?
I have standard Moode ISO, no changes in users or groups.
I have added pi user to root group and pi can see files, but what user is running moode application?

@lukas12p

None of this is necessary. You can do all your NAS configuration from the moOde UI. 

Clicking through the sequence m>Configure>Sources>CREATE NAS source will get you to the NAS source page.

Regards,
Kent
Hi Kent,
I have connected NAS, it is connected in settings without no errors, but in "Music" there is no files in NAS, but if I go to folder mnt/NAS/Muzyka as user pi logged via SSH, I can see files on NAS. I have pi user on my NAS added. What user name is executing moode app?
Reply
#7
(01-14-2019, 06:25 PM)lukas12p Wrote:
(01-14-2019, 04:43 PM)TheOldPresbyope Wrote:
(01-14-2019, 04:36 PM)lukas12p Wrote: Any suggestions on that?
I have standard Moode ISO, no changes in users or groups.
I have added pi user to root group and pi can see files, but what user is running moode application?

@lukas12p

None of this is necessary. You can do all your NAS configuration from the moOde UI. 

Clicking through the sequence m>Configure>Sources>CREATE NAS source will get you to the NAS source page.

Regards,
Kent
Hi Kent,
I have connected NAS, it is connected in settings without no errors, but in "Music" there is no files in NAS, but if I go to folder mnt/NAS/Muzyka as user pi logged via SSH, I can see files on NAS. I have pi user on my NAS added. What user name is executing moode app?

hi Lukas12p

ustaw najpierw na twoim Qunapie pelny dostep dla IP  twojego moody Rasperry .
Mialem to samo ny moim synology.

sorry for my english
Reply
#8
@lukas12p

I was going to make a comment about permissions on your QNAP NAS but @wikko13 has nicely handled it.

Once fixed, be sure that MPD has generated or updated its database to account for the files it now finds on the NAS.

Regards,
Kent

PS - Sorry for my first, terse reply. I was taking a quick break from shoveling show and didn't take time to read the entire thread.

PPS - no one here needs to apologize for language skills. The only thing I ever knew how to do in Polish was order a beer and I learned that in a neighborhood bar in Chicago.  Tongue
Reply
#9
(01-14-2019, 06:59 PM)TheOldPresbyope Wrote: @lukas12p

I was going to make a comment about permissions on your QNAP NAS but @wikko13 has nicely handled it.

Once fixed, be sure that MPD has generated or updated its database to account for the files it now finds on the NAS.

Regards,
Kent

PS - Sorry for my first, terse reply. I was taking a quick break from shoveling show and didn't take time to read the entire thread.

PPS - no one here needs to apologize for language skills. The only thing I ever knew how to do in Polish was order a beer and I learned that in a neighborhood bar in Chicago.  Tongue

Hi,
I can't add permissions for IP on NAS, only for user, that why I am asking, what user run moode app?
Reply
#10
I guess I don't understand the question. 

You've already told the moOde Samba client the username/password to be used to access the share when you used the NAS Config panel. Apparently, your share mounts with that combination. (you can ssh into your moOde player and use the mount command to see all the parameters used when the share was mounted.) 

If you can't access subdirectories and files in the share, then you have a permissions problem external to moOde.

I know nothing about QNAP so can't comment further. Perhaps someone who has succeeded with a QNAP connection will jump in.

Regards,
Kent
Reply


Forum Jump: