Thank you for your donation!


Solved: Kodi alongside MoOde
#1
First of all, I'm not sure if my issue is Kodi or moOde related but I'm asking for help here as I'm running out of luck on my own Sad

To start, this is my setup :
Raspi 3B+ with moOde 4.4 and IQAudio DAC+ connected with RCA on an analog amp and with HDMI to a videoprojector.

I used to use another audio related distribution (quite similar to moOde wich had a kodi plugin. Sound of mpd and kodi were both coming out from the DAC.

Recently I've discovered moOde while tinkering with another setup (30's radio with rpi zero and justboom amp). I was amazed by moOde reliability.

So here I am, installing it on my rpi 3B+ and trying to get the same kodi/mpd couple for my audio and video needs. But I'm unable to get Kodi to output on the IQAudio DAC...

Actually, I was, for half a minute...

So : ALSA Default (IQAudio DAC) is selected as output in Kodi. The DAC is also setup in moOde wich is working as expected.
If I launch Kodi, moOde can't play, arguing that Alsa device HW 0,0 is busy. However, Kodi sounds are coming from the videoprojector's speakers.

Today, after looking at how kodi is installed as a plugin in the other distro, I created /etc/asound.conf file with the following content.

Code:
#KODI
    defaults.ctl.card 0
    defaults.pcm.card 0
#ENDOFKODI



I launch Kodi from ssh. And it works, sounds everywhere from my beloved DAC. (Lots of joy here).
I stop the playback and try to play something with moOde wich says me : Unable to play (blah... blah...) Device HW 0,1 not found.
I look into moOde audio settings if anything has changed with mpd, which is not the case. So I'm hitting the APPLY button and go back to try moOde.
After mpd restard it works.

But then, nothing from kodi anymore and since then I'm unable to get it again, it's back to output via HDMI...

If it helps, output of aplay -l and aplay -L are IQAudio only with HW 0,0 ID.


Thanks for your help and sorry for my english, I'm not native.

EDIT : I am able to play a video with audio output to ALSA with omxplay -o alsa, if it helps...
Reply
#2
I found a solution.

It seems that it's indeed not an issue from moOde but obviously from Kodi.

Even if dt_param=audio=off is set in /boot/config, Kodi seems to activate the onboard audio. It sees the DAC not as hw:0,0 but hw:1,0.
Aplay -l/L still list only the DAC.

The workaround is to set hw:1,0 in /etc/asound.conf and reboot. Kodi the outputs to the DAC but moOde is not seeing hw:1,0.
After editing mpd.conf back to hw:0,0 in output.
And never touch anything about the mpd config in moOde GUI !

Maybe this post will help someone !
Reply
#3
I think that depends on the distribution of KODI: I had LibreELEC with Kodi on my current setup ( and no MoOde) . This worked fine and also used my HifiBerry Digi+ . I edited /boot7Config.txt and ensured that the following three lines are in it:
dtparam=i2s=on
dtparam=audio=off
dtoverlay=hifiberry-digi-pro

Also in Kodi you should select under the music the right output - otherwise Kodi will always switch to the internal output.
Reply
#4
This is interesting for me since currently I am using Kodi from inside my Amazon Fire TV stick and it does have some performance issues during movie playback (not always though).
I do have RPI 3 with Moode 4.4 and BOSS Allo DAC.
Are you able to launch Kodi within Moode? Or are you doing a dual boot on the same SD card with LibreELEC for instance?

I am quite interested in using Kodi on the RPI instead of the FireTV now.
Reply
#5
(01-29-2019, 07:04 AM)vakharia Wrote: This is interesting for me since currently I am using Kodi from inside my Amazon Fire TV stick and it does have some performance issues during movie playback (not always though).
I do have RPI 3 with Moode 4.4 and BOSS Allo DAC.
Are you able to launch Kodi within Moode? Or are you doing a dual boot on the same SD card with LibreELEC for instance?

I am quite interested in using Kodi on the RPI instead of the FireTV now.

If you are using the Stick on Wifi only it maybe that the CPU is already struggling with a weak WiFi broadcast/reception in the case of films playback (not even touching the 4K format Cool ) this Amazon accessory may give an extra helping hand if you have a LAN connection and LAN CABLE available:

                 Amazon Ethernet Adaptor
Reply
#6
(01-29-2019, 07:04 AM)vakharia Wrote: This is interesting for me since currently I am using Kodi from inside my Amazon Fire TV stick and it does have some performance issues during movie playback (not always though).
I do have RPI 3 with Moode 4.4 and BOSS Allo DAC.
Are you able to launch Kodi within Moode? Or are you doing a dual boot on the same SD card with LibreELEC for instance?

I am quite interested in using Kodi on the RPI instead of the FireTV now.

If you haven't read them, this article and this article about Kodi and FireTV options and maintenance may prove useful. There's a link in the second to information about the System X-Ray diagnostic.

If WiFi is the only possibility for access to your network, then using an HDMI cable to get the Fire Stick away from other components can be beneficial. I had to do this with my Roku stick.

Regards,
Kent
Reply
#7
(01-22-2019, 08:43 PM)retrosan Wrote: I found a solution.

It seems that it's indeed not an issue from moOde but obviously from Kodi.

Even if dt_param=audio=off is set in /boot/config, Kodi seems to activate the onboard audio. It sees the DAC not as hw:0,0 but hw:1,0.
Aplay -l/L still list only the DAC.

The workaround is to set hw:1,0 in /etc/asound.conf and reboot. Kodi the outputs to the DAC but moOde is not seeing hw:1,0.
After editing mpd.conf back to hw:0,0 in output.
And never touch anything about the mpd config in moOde GUI !

Maybe this post will help someone !

I have tried setting asound.conf and mpd.conf in the ways you have described, but cannot get the audio to play on the dac+adc. HDMI passthrough works. 

Can you show the contents of your sound conf files?

Running Kodi 18.2 and moode 5.2.

Thanks for the help!
Reply
#8
Sorry, just saw your post.

I've moved out of this solution, too much trouble, bought an apple TV.

Try to identify the ID of your DAC card with aplay -l/L, maybe yours is not listed as mine was.
Reply


Forum Jump: