Thank you for your donation!


Solved: PHP/MPD connection failure
#1
Hello there,

I use the last version of Moode. Since short time and suddently, the web interface is very slow and not usable.

The moode.log is explicit :



Code:
20180417 110917 engine-mpd: Get initial status                                                                                                                            
20180417 110917 readMpdResponse(): reading response                                                                                                                      
20180417 110917 engine-mpd: UI state=(undefined), MPD state=()                                                                                                            
20180417 110917 engine-mpd: Generating enhanced metadata                                                                                                                  
20180417 110917 readMpdResponse(): reading response                                                                                                                      
20180417 110917 enhanceMetadata(): File is NULL                                                                                                                          
20180417 110917 engine-mpd: Metadata returned to client: Size=(16)                                                                                                        
20180417 111328 engine-mpd: Connect                                                                                                                                      
20180417 111328 engine-mpd: Session loaded                                                                                                                                
20180417 111328 engine-mpd: Open socket                                                                                                                                  
20180417 111328 readMpdResponse(): reading response                                                                                                                      
20180417 111428 readMpdResponse(): error: fgets fail due to socket being timed out or PHP/MPD connection failure                                                          
20180417 111428 readMpdResponse(): error: $resp[0]=()                                                                                                                    


Can I try to fix this ?

I have a raspberry with touchscreen. It's worked just like a charm.

Thanks
Reply
#2
Since both PHP and MPD are server-side components they should always be able to communicate with one another.

Which version of moOde?
Reply
#3
Hello Tim,

I upgraded my Moode installation from 4.0 to 4.1 after my first post. Finally, it's work.

I have no explication about the cause of my problem.

Thanks for this work Tim !
Reply


Forum Jump: