Thank you for your donation!


Problem: Airplay, distortion on first seconds of every song
#1
Hi,

Happily running version 4.4 on 3B+. With the red audioquest dragonfly the sound is splendid!
I am using it exclusively through Airplay at the moment. 
The only issue I have is that the second and third seconds of every song get distorted. 
It is funny, the first couple of seconds are fine, the next couple of seconds are distorted, and then goes back to normal till the next song. 
It looked like a buffer problem to me, so I started playing with the buffer settings both on the MPD and the Airplay, but to no avail. There was no difference on the time the distortion occured no matter the settings.
I do not have any other DAC to try, but it really seems a software problem. 

Any suggestions?

Thanks!
Reply
#2
I assume MPD playback is glitch free and the glitches only occur when using Airplay??
Reply
#3
(01-27-2019, 07:35 PM)Tim Curtis Wrote: I assume MPD playback is glitch free and the glitches only occur when using Airplay??

The stereo test track and the radios play glitch free. 

The distortion seems to appear every time the iPhone (from which I stream via AirPlay) accesses Apple Music. In fact, not only the distortion appears at the begginning of each song excactly when the phone buffers the song, but also during the song if I start a “station” (i.e., a sequence of similar songs). 


Could it actually be a bug of shairport-sync?
Reply
#4
You can never rule out bugs but I use Apple Music and am not experiencing any audio glitches when streaming to moOde Airplay. This would suggest something external to shairport-sync is causing your issue,
Reply


Forum Jump: