Moode Forum

Full Version: Make SSD writable
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I connected an SSD to my Moode PI and it shows fine in Moode and plays well. It is in the media directory.

However, I cannot transfer files to it from my computer to the PI using WinSCP. The SSD is formatted ntsf. I cannot mount it in Putty as it is says it is already opened exclusively by another program (Moode).

I cannot change the directory's ownership, it just continues to say root. I have tried to set WinSCP to sudo and that did not work.

How do I make the SSD writable?

I infer from your reference to WinSCP that you are trying to copy files from a MS Windows host to your moOde player. 

Why not take advantage of the fact that moOde publishes SMB shares? Search for your player in whatever Windows calls its Network Browser these days. You'll have to authenticate as "pi/moodeaudio" to open and write to the share which is your drive but this just worked for me using the network browser on my Linux host. [Truth in advertising: I don't have an attached drive so I wrote to the SDCARD share instead.]

If you Google "linux ntfs read only" there are a bunch of links that suggest that a utility named "chkdsk" needs to be run in Windows on the disk. I have no idea what this utility does.

The format I use for disk or USB stick portability between my Mac and Linux is VFAT (Fat32). Never had any issues :-)
Ugh. NTFS. My bad, I missed that.
(07-11-2019, 02:29 AM) Wrote: [ -> ]How do I make the SSD writable?

Reformat it using an industry standard file system.  NTFS is an ancient mess and the interoperability between NTFS and non-Windows operating systems ranges between "none" and "problematic."