Moode Forum

Full Version: Missing artists... bad folder names?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I noticed last night that a few artists aren't showing up in moOde. The first one that I noticed was R.E.M., and it led me to suspect the trailing period might be an issue. It does seem to be the case -- I searched for artist folders ending in '.' and they are all missing from moOde. I noticed some folders with special characters, e.g. 'Röyksopp' are missing as well, but others, e.g. 'ROSALÍA,' are visible.

Before I blindly go changing trailing periods and special characters for underscores, I'd like to understand what the problem is. If I ssh to the pi and look at the mounted volume (my music is on a NAS), I see all the directories, so it doesn't appear to be a smb issue. Maybe MPD? moOde? How can I debug?

I'd rather catch all the issues at once than realize that I've missed other special cases. Is there a guideline for folder naming?

Thanks in advance!
I did a regen of my music library and tailed the MPD log. I noticed that it isn't even looking at folders with trailing '.'s in the names. Also, the Röyksopp example was kind of a red herring -- the only album inside is called 'Melody A.M.' (trailing period) so MPD is probably omitting artist folders with no valid content inside.

The other thing I noticed is that when I go to the mounted smb volume on the RPi, I can see 'R.E.M.' if I do a ls, but it isn't actually a directory... So it looks like I need to change all folders with trailing periods so samba can use them.
This is solved now (I think).

From my mac (terminal) I can open the SMB mounted volume on the NAS and both list and open these directories with trailing periods.

If I ssh to the RPi and go to the CIFS mount (e.g. /mnt/NAS/MuiscNAS) these directories are visible with ls. However, they aren't actually valid directories. You can cd into them, but ls inside them gives an error.

Anyway, my fix is to (from the mac), find all directories with trailing periods (find . -type d -name '*.') and append an underscore after the period. It seems to work now.

Also, the Röyksopp example from above was a red herring because it contained a single album that ended with a period.
Although Linux/Unix considers pretty much any character as valid in a file or directory name there are a lot of characters that should never be used because they have special meaning or cause shell actions to be performed if the program parsing the file or directory name doesn't account for them. A quick search and link to some guidelines

IME the music managers I've used will substitute an underscore for any special characters it encounters when creating directories from the tags.

What software did you use to create the directories?
What Tim said.

As well, the trailing dot will give any Windows system problems.

For all that, the trailing dot does not seem to be a problem in the test I just did with my OpenMediaVault server (based on Debian Linux).

I created directories containing a trailing dot and whether I served them via SAMBA or via NFS protocols, moOde/MPD picked up the tracks in the subdirectories. This was true even with trailing dot in more than one intermediate directory.

I see the directory/track hierarchies in the Library Folder view and everything looks ok in the Tag and Album views.

You might want to check such mundane issues as file permissions.

As for various accent marks I think almost any UTF-8 character should be acceptable to moOde/MPD. Certainly I have many tracks in my collection with names in various European languages.

When I tried mkdir R.E.M. on an attached VFAT USB stick it made R.E.M w/o the trailing dot. Odd.
Thanks for the responses.

Tim, I actually built the library up over several years manually, with a simple Artist/Album/ hierarchy. I think the naming would depend on the ripper I used (currently XLD), but many of the discs could have been ripped a decade or more ago, and I might have manually named tracks/folders.

Actually, when I got serious about using the NAS and streaming, I paid for a Tag Editor license and it's possible I used it to fill in some missing metadata from really old rips.

So there's no way to tell how I wound up with folders with trailing periods, but I'm guessing some of it was me doing it manually, which wouldn't have been a problem when I used to have my whole library on my laptop HD.

TheOldPresbyope, renaming the folders was sufficient to fix the problem. There are no permission issues that I'm aware of. I suppose it could be a CIFS implementation issue with my Synology NAS, but then again my mac has no problem navigating these folders via GUI or command line (via smb mount).
(07-11-2020, 02:29 PM)Tim Curtis Wrote: [ -> ]When I tried mkdir R.E.M. on an attached VFAT USB stick it made R.E.M w/o the trailing dot. Odd.

I just tried creating R.E.M. via my mac (terminal) both on the local filesystem and on the mounted NAS volume. Both were successful, and I could ls, touch files within, etc.

Then I ssh'd in to my RPi and went to /mnt/NAS/blah/ and could see the R.E.M. I had just created. I could cd into it, but if I ls, it says:
    ls: cannot open directory '.': No such file or directory

I wonder if the mac samba implementation has a built in workaround for this type of problem...
FYI, I could create directory names like "R.E.M." and "Sony." usking mkdir (in bash shell) on my Debian OMV host but not on my Raspbian moOde host, which is based on Debian. Something funny going on but I'm not going to waste time chasing this one down.

The OS X shell might be a bit different than RaspiOS shell and thus the weirdness with trailing dot.

Btw, below are lines from moOde smb.conf to deal with some of those those annoying OS X dot files.

veto files = /._*/.DS_Store/
delete veto files = yes
Pages: 1 2