Moode Forum

Full Version: Installing Roon Bridge on Moode (updated for Moode 7.1.0+)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Roon can do volume control in-app and allows the user to set "device", "fixed" or "dsp" volume for each device depending on the endpoint's capabiilities.

On my Pi running Moode Roon allows to set any of these in the device settings.

Fixed is well, fixed and thus removes the in-app volume control for the device, device changes the ALSA volume for the Pi's selected sound device, e.g. this...

... and DSP changes the volume at the source stream using DSP. DSP volume seems to be only for Roon native devices using the RAAT protocol (which Roon Bridge does of course).
All is probably explained better in this Roon knowledgebase article.

For my Hi-Fi's DAC I have it set to fixed as volume is controlled at the amp, initally I think it was set to device by default after enabling it in Roon.
In terms of hardware volume my Topping D50s DAC doesn't do software controllable hardware volume (the D50s' internal volume is only controlled with a real remote).
Looks like just different terminology for volume control modes

DSP = Software volume
Device = Hardware volume
Fixed = 0dB or whatever fixed value is set

The lack of a local config like Squeezelite has where the volume mode can be specifically set means that if user chooses DSP or Fixed volume in the Roon app and their device has Hardware volume there is no way for moOde to know that ALSA (Hardware) volume needs to be automatically set to 0dB.

Did you have to set ALSA volume manually to 100%?
Nope have never set the alsa volume, have always had volume disabled in the MPD settings also.
However setting volume to device in the device's settings and changing the volume in Roon you can see that device's volume change in alsamixer.

Yeah DSP is like software volume, it seems to be applied at the server rather than on the audio device/endpoint.

Extra test...
Yes there could be a situation where Moode is showing the wrong volume in the web UI when the alsa volume is changed by another application.
With the Roon device's volume set to device and the mpd mixer setting set to hardware I can change the alsa volume in both Moode UI and Roon. Changing volume in Moode is also seen in real-time in alsamixer & Roon but changing it in alsamixer or Roon doesn't change the volume displayed in Moode's web UI.
Then you got the situation if mpd is set to software mixer but you can have alsa's volume changed by another application causing inconsistent volumes.
Ok, the MPD "Disabled" setting would have auto-configured ALSA volume to 100%.

The renderer framework in moOde will behave consistently only when the renderer can be configured for or defaults to Software volume. This is the case for Bluetooth, Airplay Spotify and Squeezelite. They can be configured for Hardware volume but it requires manually editing their config files or in the case of Squeezelite adding a param to the Options setting.

I suppose for RoonBridge there could be a NOTE under the feature that states the MPD volume setting should be configured to match the Roon volume setting. Something like that.
Does the roonbridge binary have some cmd line params for example --version or --help?
Nvm, I see that there is a VERSION file in the app dir and that the roonbridge executable is apparently a C# app thats running under the Mono interpreter. I always thought it was a C/C++ app compiled natively for Linux.

In any case I think I've got it sorted :-)
I tried to install Roon bridge in Moode. Here is what happened. Don't know what that means.

pi@moode:~ $ curl -O
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0curl: (7) Couldn't connect to server

It is an Allo USBridge Sig running latest Moode.
(02-24-2021, 05:15 PM)SeanLL Wrote: [ -> ]I tried to install Roon bridge in Moode. Here is what happened. Don't know what that means.

pi@moode:~ $ curl -O
 % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current                                              
                                Dload  Upload   Total   Spent    Left  Speed                                                
 0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (7) Couldn't connect to server

It is an Allo USBridge Sig running latest Moode.

It means pretty much what it says, curl couldn't connect to the RoonLabs server. May be a transitory problem or a DNS issue at your end. Can you ping

The same link worked for me here just now.

Just stick to the initial guide, the curl suggestion is more appropriate an automated programmatic process.
Pages: 1 2 3