Moode Forum

Full Version: LCD/OLED display using pydPiper
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
Hi P,
Happy to see it worked. Will update the tutorial soon.
Hi moOde fans,
I have not tried anything that big but it should work with pydPiper, as long as it has a parallel or i2c interface. 
I will advise to look for an oled display instead of LCD. It is more expensive, but easier to read than a LCD.
Hi moOde fans,
(11-10-2018, 09:25 PM)JST1963 Wrote: [ -> ]Hey Remy,

At "Farnell" (without advertising this site) I have found a bunch of graphic displays with a resolution of 256x64 with parallel IF, none with I2C (search for "oled graphic displays").
Do you think they will work with pydPiper?

Thx in advance,
Hi Johan,
Sorry for the delay. Was out of town. Yes i can see these "Graphic OLED, 256 x 64 Pixels, Yellow on Black, 3V, Parallel, SPI, 84mm x 25.8mm". These are very nice and large but uncommon displays. The parallel interface here seems to have about 30 pins. I don't know if it will work because the parallel interface i am used to have only 16 pins. And at 50$ each you have to be 100% sure it will work before you buy it. If you can settle for a 20x4 character or a 128x64 pixels oled display, you will buy something that you are certain will work because others have already used it.
Hi moOde fans,
Hi Johan. I am using 2 character displays at the same time thanks to pydPiper. Each display is configured independently. It will really be nice to have one display showing only the coverart (full screen all the time) and another showing the song information but i don't know if it is possible other than by using a small screen connected to hdmi and a character display gpio connected. But on the small screen you will have the moode audio web interface, not only the cover art. 
(11-13-2018, 06:56 PM)JST1963 Wrote: [ -> ]And how do you access the i2C bus if your DAC-board uses the connector and has no passing through pins?Thx,


You can use a "multiplexing board".
Hi. Thanks for the detailed tutorial.

I´m trying to get a 16x2 i2c lcd to work. I´ve run the script on my old RPi1 running a fresh install of Moode 4.3

Here is the output:

pi@moode:~/pydPiper $ sudo ./
Installing Docker from the convenience script

# Executing docker install script, commit: 46dc063
+ sh -c apt-get update -qq >/dev/null
+ sh -c apt-get install -y -qq apt-transport-https ca-certificates curl >/dev/null
+ sh -c curl -fsSL "" | apt-key add -qq - >/dev/null
Warning: apt-key output should not be parsed (stdout is not a terminal)
+ sh -c echo "deb [arch=armhf] stretch edge" > /etc/apt/sources.list.d/docker.list
+ [ raspbian = debian ]
+ sh -c apt-get update -qq >/dev/null
+ sh -c apt-get install -y -qq --no-install-recommends docker-ce >/dev/null
If you would like to use Docker as a non-root user, you should now consider
adding your user to the "docker" group with something like:

 sudo usermod -aG docker your-user

Remember that you will have to log out and back in for this to take effect!

WARNING: Adding a user to the "docker" group will grant the ability to run
        containers which can be used to obtain root privileges on the
        docker host.
        Refer to
        for more information.
Enabling docker

Job for docker.service canceled.
Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?
Testing docker

docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?.
See 'docker run --help'.

I´ve try 'sudo usermod -aG docker pi' but it gives me the same output.

Many thanks.
Hi. Looks like there is a problem with the docker not installed properly. Remove the docker and reinstall. Or install it on a new image.
To remove the docker:
sudo apt-get purge docker-ce
sudo apt-get autoremove
rm -rf /var/lib/docker
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18