Moode Forum
Allo USBridge Signature - Printable Version

+- Moode Forum (
+-- Forum: Audiophile (
+--- Forum: Audio gear (
+--- Thread: Allo USBridge Signature (/showthread.php?tid=1704)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24

Allo USBridge Signature - Tim Curtis - 09-08-2019


This thread is for discussing the new Allo USBridge Signature product that has recently launched.

The Sig is based on a Raspberry Pi CM3+ Lite and is designed to be an ultra low noise, clean power compute and I/O platform for HQ audio. There are separate Ethernet and USB busses and a custom driver that bumps the Ethernet port speed to 330 Mbps. It also accepts 40-pin HAT audio boards :-)



Compute Module: Raspberry Pi CM3+ Lite 1GB
 USB 2.0 ports: 1 x USB CLEAN, 2 x WiFi/BT (Texas Instruments TUSB4041l)
   USB current: 900mA total
     HDMI port: 1 x HDMI
 Ethernet port: 1 x GigE (ASIX AX88179_178a)
       MicroSD: Card slot for OS (8GB or above)
    Power port: 5V/3A USB-C connector
    LED Status: PWR (green), ACT (red)
   Earth point: Optional earth connection to PCB


RE: Allo USBridge Signature - - 09-23-2019

Yeap we are also here to answer questions

RE: Allo USBridge Signature - Tim Curtis - 09-26-2019


Just completed initial tests of upcoming moOde 6.3.0 release (October) with SIG + Shanti + Katana + Comfast CF-912AC WiFi adapter + custom Eth/USB driver and all is working nicely :-)

Compliments to the Allo team for their fantastic support and their commitment to Open Source!


RE: Allo USBridge Signature - Tim Curtis - 09-28-2019


Here's some screen shots of the SIG + Katana + Comfast CF-912AC adapter.

The right angle USB connector is:

[attachment=787] [attachment=788] [attachment=789] [attachment=790]

RE: Allo USBridge Signature - weaver - 09-29-2019

New USBridge worked fine out of the box, however after applying the in place update have lost ethernet connectivity. Re-reading the Allo manual is this likely to relate to the passage about ASIX driver needing to be updated manually? As moOde was pre-loaded and came with the updated driver (according to the Allo document) I read it as meaning further updates would be fine - but I may well have got that wrong. Just to add, moOde still boots fine and with monitor attached I can see that and log in, but I can’t use the web UI.
Also, I have two other pi installs of moOde, I haven’t tried, but would just pulling the card from one of these work in USBridge? I don’t have the facility to back-up or create a new card image with me today so don’t want to just try one to see.

RE: Allo USBridge Signature - Tim Curtis - 09-29-2019


I'm not sure what version of moOde or Linux kernel Allo is using on the SDCard they bundle with the SIG but applying an in-place update, assuming it completed successfully, would not cause loss of Ethernet function. The update would however, depending on which kernel Allo used, revert the ASIX Ethernet/USB driver to stock. This would just mean that the USB port would run at a lower data rate than with the enhanced ASIX driver.

Did u monitor the in-place update via ssh command moodeutl -l ??

A stock moOde 6.2.0 image followed by the 6.2.1 update should work fine on the SIG. That's what I used for testing and for building the upcoming 6.3.0 release.


RE: Allo USBridge Signature - weaver - 09-29-2019

Thanks Tim, no I didn’t monitor unfortunately. On boot the only thing that I spotted that comes up red as failed is failed to start rng tools service.
Is there anything else I can usefully check on the install as it is? I have only ever dipped into commands enough to get things working; as moOde has been running flawlessly for several years it’s a good while since I had to try and find my way around!

Edit: the most recent version I have on an existing/working Pi is 4.4 - so a bit behind there.

RE: Allo USBridge Signature - Tim Curtis - 09-29-2019

It looks your build is broken.

Just download a fresh 6.2.0 image from and then write it to an SDCard.

RE: Allo USBridge Signature - weaver - 09-29-2019

OK thanks, will do.

RE: Allo USBridge Signature - weaver - 09-30-2019

That worked. All good now. Currently using USB out to offboard DAC but intend installing my existing Katana stack on top as well.
Just to check that switching between an i2s DAC and USB involves either one or two changes in settings:
Audio Config : devices : i2s audio device or none -
but does MPD config need to be edited each time when switching as well - to switch device.
Sorry to ask, but having got it working and then not working I didn’t quite establish which was actually necessary to get it to work in the first place.