Moode Forum
static playing high bitrate FLAC files - Printable Version

+- Moode Forum (http://moodeaudio.org/forum)
+-- Forum: moOde audio player (http://moodeaudio.org/forum/forumdisplay.php?fid=3)
+--- Forum: Support (http://moodeaudio.org/forum/forumdisplay.php?fid=7)
+--- Thread: static playing high bitrate FLAC files (/showthread.php?tid=3393)

Pages: 1 2


RE: static playing high bitrate FLAC files - poodytang - 01-18-2021

(01-18-2021, 06:45 PM)TheOldPresbyope Wrote: @poodytang 

DRONE7 is quite right that your system may be marginally powered and I would fix that problem for its own sake.

Nevertheless, the noise you describe does not sound like a power problem to me. If the drive were under-powered and hence slow to respond, I would expect you to experience buffer underruns which result in audio dropout rather than "static or white noise on the track with very high levels of distortion." An easy way to test is to copy some of your problematic files to your uSD card, disconnect the drive, and see if you still get the same noise or not when playing the files. If you don't, then yeah, the drive and power are suspect.

If you do however, then, as TIm said, this is reminiscent of a different issue. Since the pi2aes docs claim it "converts the RPi I2S stream to AES3/SPDIF formatted data at 24-Bit up to 192Khz Frame Rate" it would seem like starting with 24-bit material would be ok. Nevertheless, you can try what was suggested.

FYI, I have a number of "high def" files I've downloaded from 2L to an SSD that is plugged into and powered by an RPi4B+. They are "24-bit/88kHz" and "24-bit/176kHz" FLAC and play back without any issue through my Khadas Tone 1 board. SoX is not enabled. Because of the USB handshake with moOde in which the board advertises itself as capable of S16_LE and S32_LE (but not S24_LE), the 24-bit samples are being byte-extended to 32-bit on output, so the output stats are 32-bit/176.1kHz.

Regards,
Kent
Okay, I will try with the 5v/3a psu i have and just the pi, if that doesn't work, I will try to use a ssd regardless. I think some of my files are 10mb/s bit rate which might be a huge strain on the hdd even if it were fully powered. I am not using any output from the pi2aes, though this problem was common even when i was. I am just using the usb out from the pi thru moode, with the pi2aes attached.

Thanks for all the quick replies!


RE: static playing high bitrate FLAC files - poodytang - 01-18-2021

(01-18-2021, 06:55 PM)grumbleweed Wrote: Also check ALSA volume is set to 100%, I've encountered the 'static' issue with DSD files and this fixed it.

It is already set to 100%.


RE: static playing high bitrate FLAC files - TheOldPresbyope - 01-18-2021

@poodytang

24-bit/192kHz x 2-channel = 9.2 megabits/s = approximately 1.2 megabytes/s. That's not much of a burden for a hard drive even through a USB2.0 interface. But you can measure the average throughput with simple file-transfer timing tests. Sure, SSD should be faster, but this may be irrelevant for the problem at hand.

And you're talking about PCM-encoded files so either software or hardware control can be applied. DSD-encoded material is a different kettle of fish.


Regards,
Kent