Moode Forum
CamillaDSP - Printable Version

+- Moode Forum (http://moodeaudio.org/forum)
+-- Forum: moOde audio player (http://moodeaudio.org/forum/forumdisplay.php?fid=3)
+--- Forum: Support (http://moodeaudio.org/forum/forumdisplay.php?fid=7)
+--- Thread: CamillaDSP (/showthread.php?tid=3645)

Pages: 1 2


CamillaDSP - zulizu - 03-25-2021

I'm trying to use a filter that is working just fine in Roon, but I'm getting strange sounds when using them.
The file is a .wav which is converted to two .raw files by Moode. I'm using the "quick convolution filter". If I go to the pipeline editor I'm getting this error "Invalid filter 'ir_left'. Reason: Could not open coefficient file '../coeffs/Cor1S44_L_44100Hz_32b.raw'. Error: No such file or directory (os error 2)" , but if I pick the file manually everything is fine.

I've attached the original filter if anyone can check it.
Thanks!
R


RE: CamillaDSP - bitlab - 03-25-2021

@zulizutThanks for reporting. The conversion of the wave file goes indeed wrongwrong.

Cause:
The source is a 64bit floating point pcm and is convert to two 24bit floating point pcm file, while expected 24-bit Signed Integer PCM.
I will supply a fix to @Tim Curtis for the next update, to convert it just to a raw 64b floating point file.

Workarround 1:
  • Convert it external to a 32, 24 or 16 bit Signed Integer PCM wave
  • Upload the ir again
  • Converterd it again with the moOde convert button
Workarround 2 (If you feel comfortable with a command prompt):
  • Upload the wave file again
  • DON'T presse convert
  • Open a command prompt an run the followin commands:
Code:
cd /usr/share/camilladsp/coeffs
sox Cor1S44.wav -b 64 Cor1S44L_44100Hz_64b.raw remix 1
sox Cor1S44.wav -b 64 Cor1S44R_44100Hz_64b.raw remix 2



RE: CamillaDSP - zulizu - 03-27-2021

@bitlab
thank you for your help! I've converted the file using your commands. The import is now correct, but I'm experiencing the same echoed and heavly distorted music Sad
Just to confirm the format is still S32LE?
Do you think that problem can be that the RaspPi3 is not enough?
Thanks
R


RE: CamillaDSP - bitlab - 03-27-2021

@zulizu with the commands above the output format after the convert is 64 bit float, so change setting to match that will probably fix it.


RE: CamillaDSP - zulizu - 03-27-2021

(03-27-2021, 06:45 PM)bitlab Wrote: @zulizu with the commands above the output format after the convert is 64 bit float, so change setting to match that will probably fix it.

Yes, it fix it, so the music is ok! Great!
But I'm still getting the error in the pipeline editor. Not sure if this is a "real" error...


RE: CamillaDSP - bitlab - 03-27-2021

@zulizu The camilladsp config it fine, don't worry. Only the camillagui can not handle the relative paths.
The moode should handle this by setting absolute paths. I think I found an issue with that the first time an configuraiton is activated.

Can you do the following to see it fix the error:
  • go to the moode camilla config page
  • select as active config the default 'flat'
  • press save
  • select as active config the 'quick convolution filter'
  • press save
  • open the pipeline editor again to check if the error is gone.



RE: CamillaDSP - newbie - 03-27-2021

(03-27-2021, 06:59 PM)zulizu Wrote:
(03-27-2021, 06:45 PM)bitlab Wrote: @zulizu with the commands above the output format after the convert is 64 bit float, so change setting to match that will probably fix it.

Yes, it fix it, so the music is ok! Great!
But I'm still getting the error in the pipeline editor. Not sure if this is a "real" error...

Hi,

I ran into the same issue,  I just add the path /usr/share/camilladsp/coeffs/ in front of the filename and save it.


RE: CamillaDSP - zulizu - 03-28-2021

@bitlab : your procedure solves the problem. Now the filters are saved as "/usr/share/camilladsp/coeffs/Cor1S44L_44100Hz_64b.raw", as @newbie have suggested.
Thank you all!


RE: CamillaDSP - JWahle - 04-04-2021

(03-28-2021, 07:59 AM)zulizu Wrote: @bitlab : your procedure solves the problem. Now the filters are saved as "/usr/share/camilladsp/coeffs/Cor1S44L_44100Hz_64b.raw", as @newbie have suggested.
Thank you all!

You can also fix that from the GUI:
In the "Filters" tab for all your convolution filters click the "pick filter file" button and reselect your filters.
They should now have absolute paths now.


RE: CamillaDSP - bitlab - 04-04-2021

(04-04-2021, 04:39 PM)JWahle Wrote:
(03-28-2021, 07:59 AM)zulizu Wrote: @bitlab : your procedure solves the problem. Now the filters are saved as "/usr/share/camilladsp/coeffs/Cor1S44L_44100Hz_64b.raw", as @newbie have suggested.
Thank you all!

You can also fix that from the GUI:
In the "Filters" tab for all your convolution filters click the "pick filter file" button and reselect your filters.
They should now have absolute paths now.

The "Quick convolution filter" configuration is generated after each moOde restart of if select as active config. So fixing the paths in teh GUI is very temporary.

The idea is that moOde fixes relative paths on config activation. In this way you will always be save, only it contains a bug.
Which is fixed and will be available in moOde 7.2.0. Just like 32b/64b float wave file converter for will also be present in 7.2.0.