Thank you for your donation!

Problem: Tidal not working anymore
Hi everyone,
I'm new in the forum but I'm using moOde on a raspberry Pi 4 + hifiberry since july.
I'm using mainly with Tidal (non Tidal Connect but tidal Upnp direct from moOde), the sound quality is fantastic, the system is stable and reliable and I was controlling everything from my iPhone with Lumin app.

The system was working really well until last week.
If I use an internet radio on moOde everything is ok.
But If i try to stream from Tidal is not working anymore. I tryied Lumin, Teac Streamer app, Mconnect, but the problem is the same "no client".
I tried reboot, reconfigure, etc etc but is working.

My feeling is that moOde is having problem accessing to Tidal, and when i try to control it from an app it does not work.
I tried to stream from Tidal app using "tidal connect" and Airplay and it is working, but the sound quality is definitely worst.

Does anyone experience this problem?
DO you have any suggestion?
Thanks a lot for your help and support,

Are you using the TIDAL credentials in the moOde UPnP renderer? If so, be aware that the code underlying that falls foul of way that TIDAL revoke access keys. In fact that route is being removed from the next release of moOde because it simply cannot be relied upon any more. I believe the accepted way to stream TIDAL is to connect to your account in a control point such as BubbleUPnP (possibly Mconnect also has the ability, IDK), then use that to send the audio to moOde as a UPnP renderer.
Since this week, Tidal no longer works with me via the Lumin app in combination with Bubble upnp server.
As I understand the OAutH token api of Tidal has changed which is no longer supported by the Lumin app.
Mconnect is an option, but then your phone is also the transmission hatch.

I have now installed piCore player and LMS on my Rpi4b with Ipeng on my iphone and this sounds and works very well.
I'm going to give this a chance for now. Although I thought Moode really enjoyed working.
Hi RM, one question: with the piCore+LMS package the phone works as a "streamer" (like Lumin+moOde) or the phone is the player and the Rasp works as a receiver?

Is there a way to play/use Tidal directly on Raspberry? I could connect a touch screen to it and streams Tidal directly from It.
I'm a member of the BubbleUPnP Google Group and a recent post on this by Bubbleguuum ( the developer of BubbleUPnP et al)  informs that there had been two methods to login to TIDAL: the old method (a login/password based) and the new method (using OAuth2 via a TIDAL web form).  Tidal has apparently just pulled the plug on the old method, which had been used by BubbleUPnP, and that's why it no longer works.  In other-words, this issue is isn't anything to do with Moode, BubbleUPnP, or by the sounds of it Lumin or mConnect, but is instead due to a decision by Tidal, who is now requiring that the login process be OAuth2 based.  Bubbleguuum comments that alterations are intended to BubbleUPnP Server and Android BubbleUPnP to overcome this but by the sounds of it this could be far from trivial to implement, so I'm guessing may take time.

Forum Jump: