Thank you for your donation!


Multicast DNS (mDNS) discovery
#11
(03-08-2019, 06:37 PM)TheOldPresbyope Wrote:
(03-08-2019, 05:58 PM)fabnavigator Wrote:
(03-08-2019, 05:40 PM)Tim Curtis Wrote: Examine the following files and verify correct hostname

/etc/hostname
/etc/hosts

The avahi service name is generated dynamically in this file via %h
/etc/avahi/services/moode.service
Here are my files:

/etc/hostname:

master-bathroom

/etc/hosts:

127.0.0.1       localhost
::1             localhost ip6-localhost ip6-loopback
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters

127.0.1.1       master-bathroom

Found on the ArchWiki (https://wiki.archlinux.org/index.php/avahi)

Quote:Troubleshooting

Hostname changes with appending incrementing numbers

This is a known bug that is caused by a hostname race condition. One possible workaround is disabling IPv6 to attempt to prevent the race condition. If multiple interfaces are present use allow-interfaces to limit Avahi to a single interface. Another possible workaround is to disable the cache to prevent Avahi from checking for host name conflicts altogether, but this prevents Avahi from performing lookups.

Certainly, wasn't known to me  Tongue

Since the bug has never occurred in my environment, I can't attest to the workarounds. Disabling IPv6 would be easy but IPv6 is enabled on my hosts (although not in use) so there you are. Are you perhaps using multiple interfaces?

Regards,
Kent

What do you mean when you ask am I "using multiple interfaces"?
Reply


Messages In This Thread
Multicast DNS (mDNS) discovery - by fabnavigator - 03-03-2019, 12:19 PM
RE: Multicast DNS (mDNS) discovery - by fabnavigator - 03-08-2019, 07:09 PM

Forum Jump: