Thank you for your donation!


Problem: Pi4 and Library Update - never finishes?
#10
@seanleblanc

The symptom "the page is unresponsive, page does not refresh" might suggest that the mpd process has halted but the symptoms "I can no longer ssh in, nor even ping" suggest a more basic problem(s). 

@vinnn has already suggested one possibility, a bad uSD card (or bad flash of the moOde image to the card). This was a bigger problem in the past than it seems to be now but it's always a possibility. The brand and model you name are high quality (be sure you get a genuine article and not a counterfeit). As an aside, I consider a 128GB card to be serious overkill---an 8GB or 16GB card for moOde and a large USB thumbdrive or SSD for music makes more sense. Sooner or later you'll be reflashing moOde and you'll hate yourself if you have to reflash a big music librarySmile

Another possibility is inadequate power to the RPi. The moodeutl log which Tim has suggested will show useful information if you're suffering undervoltage conditions.

I could make other conjectures but it's pointless without more information.

As for track metadata, mpd does *all* its indexing based on the track metadata. Malformed metadata can stop mpd. See, for example, the discussion MPD troubleshooting on the Arch LInux Wiki. You can see where mpd stops indexing by examining the log file /var/log/mpd/log

The first thing we need to see to help debug further is the command-line output from moodeutl -l as Tim suggested.

Regards,
Kent
Reply


Messages In This Thread
RE: Pi4 and Library Update - never finishes? - by TheOldPresbyope - 03-27-2021, 04:49 PM

Forum Jump: