The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 906 - File: showthread.php PHP 7.2.34 (Linux)
File Line Function
/showthread.php 906 errorHandler->error



Thank you for your donation!


Solved: No sound on usb dac when using bluetooth/airplay
#1
Hi.

Need some help figuring this out...

Need moOde on my pi zero w to be able to play through bluetooth/airplay to my Chord Mojo.

I can connect with bluetooth and airplay fine and play audio if the onboard audio card is selected. If I select the USB output (the Mojo) then it disconnects bluetooth and will no longer pair (same with airplay).

I have no problem with the Mojo connected and playing webradio from the webinterface through moOde (sounds fine on the Mojo), but if I use bluetooth or airplay then nothing happens (other than the phone will disconnect when the usb is selected as output).

Any ideas?

Using latest version 4.3 2018-09-27. 



Code:
 usb 1-1: new high-speed USB device number 3 using dwc_otg
 usb 1-1: New USB device found, idVendor=245f, idProduct=0815
 usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
 usb 1-1: Product: Mojo
 usb 1-1: SerialNumber: 413-001
 usb 1-1: Warning! Unlikely big volume range (=32767), cval->res is probably wrong.
 usb 1-1: [10] FU [PCM Playback Volume] ch = 2, val = -32767/0/1
 usb 1-1: Warning! Unlikely big volume range (=32767), cval->res is probably wrong.
 usb 1-1: [10] FU [PCM Playback Volume] ch = 1, val = -32767/0/1




Code:
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 7/7
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Mojo [Mojo], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Code:
pi@moode:~ $ lsusb
Bus 001 Device 004: ID 245f:0815
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Reply


Messages In This Thread
No sound on usb dac when using bluetooth/airplay - by Viol8r - 11-04-2018, 08:28 PM

Forum Jump: